Support » Plugin: Polylang » theme independent polylang – customizer issue

  • Resolved Gabor Lippert

    (@lunule)


    Hi Chouby,

    Polylang seems breaking the customizer when menus have different language versions.

    There’s an error message displayed a lot of times (probably the number of menu items) saying:
    “Warning: array_key_exists(): The first argument should be either a string or an integer in [siteurl]\wp-includes\cache.php on line 669”

    Customizer screenshot.

    The site is under local development, using the WAMPP local server solution.

    1. WP version: 4.1
    2. Polylang version: 1.6.1, also tested with 1.5.5, 1.5, 1.4.5 with the same results.
    3. Theme: custom developed theme but tested with TwentyThirteen and TwentyFifteen with the same results.
    4. Polylang settings

    Thanks for your help in advance!

    https://wordpress.org/plugins/polylang/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Chouby

    (@chouby)

    Hi!

    Could you precise the steps to reproduce this error? Just to be sure, did you check without any other plugin activated?

    Hi,

    Sure – it seems that this problem only appears when a static page is set as the site’s homepage (either in the Customizer or in the backend, Settings -> Reading).

    And yes, just re-checked it without any other plugin acivated, and the messages are there.

    Also they certainly have something to do with the menu items. They appear at first above the main header menu, then another time above the footer menu items – nowhere else.

    (There’s also a chance that some WP bug is causing the problem – at least six days ago another thread has been submitted with the same problem, but affecting the Rating Widget plugin.)

    Ulrich

    (@grapplerulrich)

    I have the same issue and was able to replicate with the same steps.

    Ulrich

    (@grapplerulrich)

    Here is a screenshot of one of the error with xdebug.
    https://www.dropbox.com/s/ulm8yhxy744yf7u/Screenshot-20141206001.jpg?dl=0

    Let me know if I can help with anything.

    Ulrich

    (@grapplerulrich)

    I was able to fix the issues by adding the following code to line 388 in include/model.php

    if ( ! is_numeric ( $post_id ) ) {
    	return;
    }
    Plugin Author Chouby

    (@chouby)

    Hi!

    Thanks Ulrich. I ran into the same issue and forgot to come here to inform. I believe that it is solved in the development version (I preferred to fix PLL_Model::get_object_term)
    https://downloads.wordpress.org/plugin/polylang.zip

    Ulrich

    (@grapplerulrich)

    Thanks, it works!

    @ulrich, @chouby – great thanks guys!!!
    Just downloaded the dev version, and everything works fine.

    I’m marking the topic as resolved.

    I guess this will solve my problem as well. One question: how do I update the plugin to dev version? Just replace old wp-content/plugins/polyglang folder with new? Is it going to overwrite my current polylang settings? Thank you very much?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘theme independent polylang – customizer issue’ is closed to new replies.