Support » Installing WordPress » Theme incompatible with 2.0.4 or what?

  • Schadeboy


    Hello, everyone. I hope your day is going well. Mine is fair to midlin or whatever.

    Anyway, I am having an issue to which I do not seem to be able to solve. Nor does anyone here seem to be having the same problem. At least, not that they’re admitting to.

    I want to upgrade my site to version 2.0.4, but whenever I do, the theme it uses gets broken. The only thing that will display is the header. Nothing else. Calls to the other parts of the page are either ignored or have an error reported saying the function is not defined.

    The theme works perfectly in 2.0.3. I can revert back to that version with no problems because I remembered to back up all of the files prior to the upgrade. So for now, the site works. But I’d like to get the fixes that 2.0.4 provides.

    I use the Clean Breeze 2 theme with some modifications to it. The mods are not terribly different from what is already in the theme because I’m not a PHP programmer. I know how to cut and paste and find my way around the code well enough to make a few changes. But overall, the theme is the same. Most of my mods have been made in the stylesheet.

    A visit to the author’s web site was fruitless. The theme exists, but he doesn’t seem to have kept his blog site regarding the theme up to date. And there is certainly no mention of 2.0.4 in there.

    I’d rather not change the theme, as I have a lot of customizations already in place that I do not want to have to rebuild. Any help would be appreciated.


    I certainly hope that any previous entaglements I may or may not have had with users on this site will be forgiven. I don’t like rocking boats, or leaving behind enemies.

Viewing 7 replies - 1 through 7 (of 7 total)
  • drmike


    Calls to the other parts of the page are either ignored or have an error reported saying the function is not defined.

    When you look at your page source within your browser, what’s the last thing displayed? Any error there? You don’t mention checking there.



    When I first upgraded, the header would display an error to a function call saying “undefined function” or something like that. What it was calling was my left sidebar file called lsidebar.php. That call is coded from the original theme code, and works perfectly in 2.0.3.

    The second time I upgraded, the header would be displayed fine, with no errors. But the rest of the page would not load. Again, reverting back to 2.0.3 fixed everything and the site is working fine at the moment.



    Some of us are have this same problem. No one has come up with an answer yet. Not that I’ve noticed, though.

    When I upgraded to 2.0.4, the only theme I can use is the default one, not that I dislike it but I’d wish I could use something else.



    Actual error messages and examples are BEYOND priceless.



    HandySolo – You don’t need to tell me that twice. I work as a network engineer, and I can certainly agree with your comment. I wish I could remember exactly what the error message was. I’m pretty certain I got it right as I stated up above, though. “Call to Undefined Function” or something to that extent.

    Like I said, the second time I tried to upgrade, I didn’t get any error messages. Just the header and the information it contains. The page would stop loading from there. Again, I have no example to show because the problem was happening on my live blog, and I didn’t want to leave it that way until I figured the problem out.

    I have learned two things though. First, it’s a good idea (as many people I’m sure will attest to) to have a test site in place first. Second, Undefined Function would be an excellent name for a rock band.



    You may be on to something the rock band name idea…

    Right after “Undefined Function” it’ll list what that function was. Next time you give it a go, capture that too. A lot of times, it comes down to a borked upload – files garbled (don’t upload php files in binary mode!) or junk like that.

    And you might have a look at the apache error logs as well and see if anything interesting made it there.

    There are few other threads claiming 2.0.4 broke themes that I guess you should keep an eye on. Based on what I know of that was in the upgrade, I’m struggling with what it possibly could’ve broke… but I’m willing to be proven wrong.



    HandySolo – The function that was listed was the php file for my left sidebar. Since that was a file I created (copied from the theme-provided right sidebar file) I commented the line out. When I ran it again, this time it errored out on the right sidebar PHP file. Keep in mind, the right sidebar file was provided by the theme, and I haven’t done anything to change it.

    Since everything works as it should under 2.0.3, I can only assume that the cause is somewhere in 2.0.4.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Theme incompatible with 2.0.4 or what?’ is closed to new replies.