Support » Theme: Twenty Twenty-One » Theme down?

  • Hi,

    My website is not loading correctly.

    I see an error message when I open my site: Warning: Illegal string offset ‘custom_css_post_id’ in /home/customer/www/…com/public_html/wp-includes/theme.php on line 1063

    When I change to another theme, I don’t get this error message. The menu for customizing this theme is gone as well.

    Has there been some sort of update?

    Kind regards,

    Karen

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 25 total)
  • Have you tried deleting the theme and re-installing a fresh copy?

    Does the issue present itself when you turn off all your plugins?

    Oliver

    Thread Starter karenaug

    (@karenaug)

    Hi Oliver,

    Thank you for replying so quickly.

    I deactivated all plugins. I deleted the theme and installed it again.
    Nothing changed. It still says: `Warning: Illegal string offset ‘custom_css_post_id’ in /home/customer/www/ma…com/public_html/wp-includes/theme.php on line 1063

    It does say in the note www/ma… instead of ‘www.’
    Can this be the issue?

    Kind regards,

    Karen

    • This reply was modified 6 months, 1 week ago by karenaug.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What version of PHP are you running?

    Check Tools > Site Health > Info > Server.

    Thread Starter karenaug

    (@karenaug)

    Hi James,

    It’s 7.3.28 (Supports 64bit values)
    Do you need any more information?

    Kind regards,

    Karen

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    That should be fine.

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    • This reply was modified 6 months, 1 week ago by James Huff.
    Thread Starter karenaug

    (@karenaug)

    I am using Siteground. It has a wordpress kit. Does this then still apply?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Yes, please try a manual re-install as described above.

    There could be something wrong with Siteground’s installer.

    Thread Starter karenaug

    (@karenaug)

    Hi James,

    They don’t have a contact address. They refer for questions on wordpress to the wordpress forum. … User friendly 2.0

    All I can find is in: wordpress>Install and manage>manage installation
    There I can select ‘delete application’.

    Above is also an option to install wordpress, but I then have to select folder in my current site. Isn’t it then installing wordpress twice in my site? The folders I can choose from are: cgi-bin, wp-admin, wp-content, wp-includes`

    In security>backups I can also ‘Restore all files and databases’ from yesterday. I didn’t make big changes since yesterday, so it shouldn’t be much of an issue.

    What do you recommend or am I not even close?

    Many thanks!

    Kind regards,

    Karen

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Thread Starter karenaug

    (@karenaug)

    Hi James,

    I only have a Chromebook and it doesn’t let me install filezilla. I am going to get my normal PC fixed tomorrow. Hopefully it will work then.

    Thanks for your patience and help!!!

    Kind regards,

    Karen

    Thread Starter karenaug

    (@karenaug)

    Hi James,

    I tried to re-update the site with ftp.

    I updated the folder public_html, because that’s where my wordpress files were. There were more folders in my directory, but I assume they are from siteground.

    I left the folder cgi-bin and https. Both were empty and I didn’t find them in the new wordpress folder. Should I remove these?

    Regarding my website, nothing changed. Filezilla did give me the following error messages:

      Status: Directory listing of “/…com/public_html” successful
      Status: Disconnected from server
      Status: Disconnected from server
      Response:421 Timeout – try typing a little faster next time
      Error: GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.
      Status: Server did not properly shut down TLS connection
      Error: Could not read from socket: ECONNABORTED – Connection aborted
      Error: Disconnected from server`

    I did refresh it after, but nothing changed.

    What can I try next?

    Kind regards,

    Karen

    Thread Starter karenaug

    (@karenaug)

    I am also going to log in again after 30 minutes, because maybe it hasn’t refreshed yet.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    Thread Starter karenaug

    (@karenaug)

    Hi James,

    Thank you for replying so quickly.

    I have 3 tabs in caching:
    NGINX DIRECT DELIVERY: I can switch it on or off there
    DYNAMIC CACHE: I can ‘flush the cache’ there
    MEMCACHED: It enabled this one. And I can ‘flush the cache’ there as well

    Do you need more information? There is also some explanation on the differenct caches.

    I was using an app called polylang to translate my website. I am assuming it’s this app that created the issue. Though disabling doesn’t improve it. You are able to add a category there for a translated page and you can also add a translation for the category in the ‘category’ section. I think you then get twice a category for one translated post.

    Kind regards,

    Karen

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Don’t enable any new caches, just flush any caches you can.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Theme down?’ is closed to new replies.