Support » Themes and Templates » Theme Doesn't Look Right?

Viewing 15 replies - 1 through 15 (of 22 total)
  • It seems as though you have a broken theme – its not properly installed. Try re-uploading it using the built in theme uploader.

    By the way, that theme is not hosted here so you might want to take it up with the author for further support on it.

    It works on my iPhone http://irl-upload.com/u/1363128939.jpg but no where else. It’s weird. It also works on Internet Explorer but not Firefox nor Google Chrome.

    Your style.css imports style.css.php file in css folder that in turn imports and compresses a bunch of other CSS files.

    Now the problem is that your host apparently adds following tracking code to your generated CSS that results in content encoding error:

    <!-- Hosting24 Analytics Code -->
    <script type="text/javascript" src="http://stats.hosting24.com/count.php"></script>
    <!-- End Of Analytics Code -->

    Check with your host how you can turn it off.

    But for now you can use this as a workaround:

    You can turn off the compression, to do this change
    @import 'css/style.css.php?c=1';
    to
    @import 'css/style.css.php';
    in style.css.

    It will most likely work, but you’ll still have invalid CSS.

    You could also copy the generated CSS by visiting http://www.level-lanegaming.net/wp-content/themes/thalliumity/css/style.css.php and paste it in your style.css instead of @import rule. You will lose the dynamic ability of the CSS/PHP. This means that you would most likely need to check if the CSS output has changed and copy-paste changes every time you change theme’s options. But you’ll have a valid CSS.

    I copied everything I saw in the generated CSS and pasted it into sytle.css using FTP. Is that what you’re saying to do?

    As far as I can see you style.css is still the same.

    If you’re going to use this approach. Visit the php URL without ?c=1. Copy everything except <!-- Hosting24 etc. part. Paste in style.css instead of @import, save and re-upload overwriting the old file.

    Okay, I’ve copied everything from the URL except the hosting24 part and then accessed the FTP, passed it into style.ss, saved it, and re-uploaded it. Still no luck.

    I’m not sure you uploaded it correctly. See for yourself, the file hasn’t changed:
    http://www.level-lanegaming.net/wp-content/themes/thalliumity/style.css

    Ooops! Wrong file.

    Okay. I did! I got luck but some things are out of place like the slider in the middle. As well as the background color. Got any ideas 🙂

    You can start by commenting out @import 'css/style.css.php?c=1';. I do believe I mentioned instead, not in addition, a couple of times 😉

    Use /* and */, e.g. /* THE RULES HERE */ to comment the line out. Or you can just delete it.

    Okay! I’ve deleted @import ‘css/style.css.php?c=1’;

    Anything else?

    Okay, I see what’s going on. The path to the images is incorrect since style.css.php was in css folder and now it’s up one level. You can replace all ../images with images.

    Or the easiest thing to do would be this:
    1. copy generated CSS to a new file, let’s say mystyles.css
    2. move it to css folder
    3. in style.css remove everything you added and under

    License: GNU General Public License
    */

    add this

    @import url("css/mystyles.css");

    I did that and it went back to the original issue.

    Not exactly the same.

    The content of the mystyles.css is not exactly CSS, you can check it yourself. Recreate mystyles.css and re-upload.

    Create it in a notepad and save it as mystyles.css, correct?

    Copy style.css, rename to mystyles.css. Open in notepad, delete everything, paste generated CSS. Save and re-upload.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Theme Doesn't Look Right?’ is closed to new replies.