Support » Fixing WordPress » Theme does not exist error

  • Getting errors of the style sheet being displayed with the theme description and any changes I make via the theme editor result in ‘The requested theme does not exist.’ (but it does make the saved changes?) Switching back to connections or defaul theme has no problems.

    Facts: Using connections theme at with no problems, uploaded Travelogue latest theme 1.0.2, running WP 1.5.2.

    To clarify, this problem is just in the plain admin theme editor where you switch between themes (not the theme_switcher plugin). The entire stylesheet is displayed along with the theme description (tips me off that it has a problem), then it is again displayed in the theme editor area and pushes down the links to edit pages to the bottom.

    Also, I have run this theme about 4 months ago with little problem. I changed for awhile, and want to try it again. I deleted the theme folder, ensured I redownloaded the latest version and reuploaded all files.

    Sorry if I’m verbose, just want to make it clear. I’ll try looking in the theme-editor.php file.

    Thanks to any and all help with this, I’m sure it’s something simple and dumb I’m missing here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • If you put the error message in the search box…
    You could find out there must be something either with the lines at the top of the stylesheet or with the software you used to edit the files.

    i did search b4 posting, and now tried specifically “requested theme does not exist”, I just find the same stuff as before I first posted. I’ll go over the solutions I found and why they are not working or applicable to my situation:

    <b>1st possible solution found:</b>
    Solved this! (I’m not actually josepo, this is a bugmenot account.) This happens if you remove the commented-out sections at the top which include theme data. Reupload the CSS file with these intact and it’ll work.
    <b>Problem:</b> I have not removed any commented-out sections, these are fresh files installed. I also did double check commented sections were there to start.

    Unless this refers to a commented section in theme_editor.php? I have viewed the file (a moment ago) but never edited it.

    <b>2nd possible solution found:</b>
    The upgrade to 1.5.2 did the trick.. the theme editor is now functional.
    <b>Problem:</b> I am already at 1.5.2. (I’ve rechecked about 10 times throughout this troubleshooting process and just checked again now.)

    Another search result described a different problem in that they could not even edit files under the theme editor (I can though). Another search result describes php warnings (again not my issue).

    All other search results were not relevant or duplicate the same results.

    Any other ideas? Again, I can switch back to the connections theme with no problems. It does not display the stylesheet in the theme description like the travelogue does. (theme creator’s site at has a comment describing the same problem:

    i have just installed your theme, however (and it is not currently selected on my site), in theme selecting page, the name of your theme and the description goes on for 2-3 pages, making it very unwieldy.

    And the next comment from another user is:
    Ya, I just confirmed this bug with another guy, it appears to be linked directly to WP1.5.1.3, some extra periods were being inserted into the style.css file.
    Anyways, I’ve fixed it and uploaded a new zip of the theme, so go download it and be happy once more. You don’t need to replace every file, just style.css.
    Again, I’m on 1.5.2 so not my issue.

    Thanks again for any and all help.

    To clarify the problem a little better, in the theme editor area, I can switch between the different files (style.css, sidebar.php, footer template, etc.).

    I try entering changes and hit ‘Update File’ and that is when I get the error. I refreshed my site but no changes were made. In firefox I hit the back button and my changes are there (not groundbreaking information, but it’s what I’m experiencing.)

    Can I make these changes to the files and FTP upload them, or will that cause WP problems? (just trying to think of a workaround here until I can fix this problem).

    I always edit my files on the computer in a plain text editor and upload them via FTP. Never had any problem.

    Cool, I’ll use that as a workaround for now.

    However, my WP interface is essentially broken in the theme editor area by this problem (seemingly not any other area).

    I think a clue is that the theme editor displays the style sheet with the theme description. If I can find what is doing that, I might fix the problem.

    I’ve looked at the theme_editor.php and see the area that causes my error message:

    if ( ! isset($themes[$theme]) )
    die(__(‘The requested theme does not exist.’));

    Mmmmm, no I’m sure the theme_editor.php is fine because of the connections and default themes showing correctly.

    I again look in the theme description, and I see it is pulling the information from the top of the style.css:

    Theme Name: Travelogue
    Theme URI:
    Description: Designed with a traveler in mind, or someone with a chronologically-based blog, this theme is attractive and customizable. Don't forget to change the picture in the polaroid!
    Author: Josh Lyman
    Author URI:
    Version: 1.0.2

    Released under the GPL. The included font, "Dear Joe," is released by joebob of,
    and is free to use for any purposes. The default picture supplied in the polaroid header image is
    copyrighted by Josh Lyman. I don't care if you keep it, but recommend you change it. And please don't
    take credit for it either! ;-) Have fun!.

    /* Color Schemes
    Orange Dark: #AA3511
    Orange Light: #E0D3CD

    GreenBlue Dark: #618788
    Green Light: #D4DBD3
    Blue Light: #B6CAD1 */

    body {
    backgrou..... etc. etc. etc.

    So either the description should not be pulled from the style.css or it should only be pulling the commented area of the style.css? The comments seem valid with the asterisk and /.

    Should the theme description pull info from the style.css comments or from elsewhere?

    Thanks again,

    Oh. My. God. You’re. S^*@(ing. Me.

    I noticed in my previous post that I wrapped the entire commented and code stuff in a code tag, but it only showed code in the first paragraph. That got me thinking. So I simply removed the space from between the two commented paragraphs, re-uploaded, and it now all works perfect!

    I just uploaded my previous sidebar and it saves changes. Note that travelogue uses some hacks for the sidebar display so typical h2 tags don’t work, but that’s just a matter of time and effort to fix.

    Cool, such a simple fix.

    Again to summarize, anyone having this problem, access the style.css file outside of WP, simply delete the line space between the two paragraphs in the top comment. Upload/overwrite, of course. Hope this helps others.

    I knew it was going to be a simple fix. TG4WP!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Theme does not exist error’ is closed to new replies.