Support » Themes and Templates » Theme does not accept line breaks

  • Resolved NLXJ

    (@nlxj)


    I searched to forums to no avail.

    This theme, Dark City, has no line breaks, if you notice. This is not due to the way the posts are written. This is an error in the theme. Even if you make a line break like

    this,

    it will not show in the page, except like
    this.
    So you can’t make a space between
    the lines
    only a single break.

    Does anyone know if any code anywhere could fix this? My wrist tendons are on fire and after hours, I can’t figure it out. Any help is appreciated.

    [my sandbox adaptation of this is here]

Viewing 10 replies - 1 through 10 (of 10 total)
  • add this to your css stylesheet:

    p {
    margin-bottom: 10px;
    }

    If you want the space to be bigger, just change the 10 to whatever.

    Thanks for answering, Garbanzo. I was SO hoping that would fix it. But as you can see on the actual live site I worked on, it has not. Note the blockquote for a clear example. I changed the styles.css as you said, even made it 20px.

    Any idea why it didnt take?

    one question: would it matter where i put it into the stylesheet? or is that irrelevant? i’ve noticed with some descriptors and classes, it does seem to matter, and with others it doesn’t. is this one?

    It should be irrelevant. Maybe you hadn’t closed anything.

    hmm. well. i put it in there just as garbanzo typed it here. copy and paste. and still no luck. frustrating.

    even the comments refuse to show paragraph breaks. if that helps at all?

    In your stylesheet, find:

    #content p {
    margin:0pt;
    padding:0pt;
    }

    Comment out that margin line and try?

    #content p {
    /* margin:0pt; */
    padding:0pt;
    }

    let me try this now

    thank you all SO much. what i did was combine the info you gave me (the other approaches were not working):

    #content p {
     margin: 0;
     margin-bottom: 10px;
     padding: 0;
    }

    You have saved my life. THANK you.

    and my only excuse for missing such a retrospectively easy problem is that i’ve worked in Movable Type since 2003…this is my first WP blog. if that excuses me at all. 🙂

    thanks again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Theme does not accept line breaks’ is closed to new replies.