Support » Fixing WordPress » Theme Customizer Stuck on "Saved" (can't save!)

  • Resolved robscott

    (@robscott)


    Hi,

    Have been developing a new version of our wordpress site, and therefore making lots of changes and customizations, using a theme we developed with a few extra settings in the Customize menu, only to find after a few hours, after hitting “save” (an innocuous setting change), that the Save button was, for want of a better word, stuck on.

    To clarify, it looks like this:

    https://silicondales.com/wp-content/uploads/2016/01/theme-customizer-saved-stuck-on.gif

    Okay, I thought, this must be a caching issue. But it doesn’t look like it is:

    1) Went incognito in Chrome (the browser I was using) and no change (after re-logging in)
    2) Cleared browser cache, history, everything, restarted browser, logged in.

    Neither worked.

    3) Opened /wp-admin/customize.php in other browsers (including the ludicrous Microsoft Edge).

    Still not working.

    4) I then even tried opening another WordPress website (the site I was working on was a dev version at a secret subdirectory), and even <i>that</i> didn’t work, which suggests this is a local issue, not related to the server, but one which follows around, browser to browser, and site to site.

    Still not working.

    This is on a relatively new Windows 10 machine. The website is on a standard LAMP stack, with latest version of WP and all plugins. It was working for months (not being customised often) and then several hours, with no issue. Then stopped working.

    I just wondered if:

    a) anyone else had suffered this issue; and
    b) there is a known solution?

    I found a similar “resolved” post which was not exactly the same, and which appeared not to have an actual suggested resolution. e.g. https://wordpress.org/support/topic/theme-customizer-not-saving-issue-very-strange-one-any-idea

    I will come back and post how this was fixed if and when a solution is discovered!

Viewing 11 replies - 1 through 11 (of 11 total)
  • An update

    Logged in on ipad, via safari. Still stuck on “saved”.

    Logged onto a wordpress site on totally different hosting server. Still stuck on saved.

    Logged out and switched broadband provider. Still stuck on saved.

    Can someone, please, log in to their wordpress website and open the customiser and tell me it is working!

    I will be able to check with others at office tomorrow…

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Hi robscott!

    Hope you’re doing good. 🙂

    One thing that popped out at me when I read your post was the image. Generally that means that the state of the the site or any customization has not been made or JavaScript is somehow being prevented from changing that button’s state. One of the things they did mention in that thread was that they deactivated one plugin at a time until they were able to save.

    Does this happen when you first open the customizer? If so, that is expected behaviour. Are you able to make changes and then click the save button or does it just not change state when you make any changes?

    If you are able to provide a step by step to being able to reproduce that would be amazing so it gives us something to look for. Before doing so, please be sure to deactivate all your plugins and switching to a bundled theme like Twenty Fifteen/Sixteen.

    Look forward to being to help you out!

    Hi,

    Yes – it was stuck in “saved” on the one site, and, as you state, it is expected behaviour on the other sites (it says “saved” when you first open customizer, and then changes to “Save & Publish” after a change has been made) – hence the second half of my post is not relevant! Long day on Friday!

    The one which was “stuck” we had a PHP max execution error which was thrown by one of the functions (custom code) now fixed, and has resolved.

    Thanks for your answer, as it did help me get to the “why it didn’t look right” – I don’t use the theme customizer at all, and its like a dark recess of WP to me!!

    In short: I didn’t realise the default status is a greyed out “saved”, as I’ve never actually looked at that UI before Friday (when something ‘broke’).

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    Long day on Friday!

    I know that feeling all too well. 🙂

    Glad to see I was able to help you out.

    asma786

    (@asma786)

    I’m facing the same problem. And I’m new to wordpress. Please guide step by step. I have just five days to deliver 😟

    robscott

    (@robscott)

    Make a change, and the button should change to “save & publish”.

    If that does not happen, you have something wrong going on.

    Post a new issue on here in that case.

    Hey guys I’m dealing with this too.

    @robscott you mentioned a “max PHP execution error” what do you mean by that?

    I create a mass amount of post and pages, erased and recreated post and pages of server all occasions. All my problems began once that happened. As to say I was unable to create post or pages.

    I active problem now is my enability to edit my on any level.

    I will change content, say in the footer. In image will render the new content I just wrote, I will save. Move to a new section, say the header, with all the content in the footer the same. I will complete and save both HEADER and FOOTER, then refresh the page and all my fresh content is gone.

    This sounds similar to yalls problems.

    If I need to explain more let me know. Thanks for any help.

    P.s. This is happening to three sites that I’ve done all the same actions for as to say they all copy the same pattern. I mention to say this is not an isolated event in my case.

    Hi @anthum1 – your issue sounds like *something else* – I recommend you post a new item into the forum. Mine was from memory a php issue – I was custom coding my own customizer options in a theme.

    It sounds like you have a different issue – you’re describing the post edit screen (not the customizer).

    If you post your issue as a new forum post here, and describe it, you’ll get some help!

    I noticed your post is marked as “Status: Resolved” Topic: [Resolved] Theme Customizer Stuck on “Saved”.

    Have you resolved this issue and if you have would you please post your solution. I am having the same problem with Customizer in WordPress. Thanks.

    @periago – in my case, above, this was not an issue with WordPress, but with my theme & PHP settings. The customizer should change to “save & publish” after you make a change, if this does not happen, then you may have an issue – post a new item into the forum, and describe what’s happening!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Theme Customizer Stuck on "Saved" (can't save!)’ is closed to new replies.