Support » Themes and Templates » [Theme: Comicpress (Custom)] Navigation broken after update to 4.2.1

  • Hello, thanks for having a look at my question.

    I manage about a dozen WordPress sites using Coimicpress, and updated them all from 3.1 to 4.2.1 with no major issues, except one site.

    Site: http://themusementor.com/

    There are 140 pages on this site, but since the update only the first and last page are accessible using the navigation arrows. That is, the “back” arrow on any page goes to the first page, and the “forward” arrow goes to the last.

    Clicking any page normally advances to the next one, but since the update, each page is just a link to itself.

    All pages are accessible from the archive link if you select them individually, and they all show up in the correct order and in the right categories in the backend.

    I’ve tried taking the /comicpress/ folder from another site that is working normally, and it behaves the same way.

    I’ve tried installing the most recent version of the default Comicpress theme, and it doesn’t show any comics at all – it treats the Comics category as a blog roll.

    If I set the Comics category to be a blog, the navigation arrows forward and back both just link to “/”.

    I’ve added a new page for testing, and tried un-publishing and re-publishing various posts. The behavior stays the same, using whatever posts are the newest and oldest.

    Can anyone suggest anything I might be missing here?

Viewing 2 replies - 1 through 2 (of 2 total)
  • After posting this and continuing to work on it, I have found a solution that seems to be working: If I set the comics category to a new category, and move the posts to that cat, they show up properly.

    A pain in the butt, and I’m still not sure the cause, but it seems to be working.

    Nevermind, seemed good for a moment and then reverted behavior.

    Did you ever find a fix for this? Our host auto updated the comicpress theme to 4.2 and it broke quite a few things. Rather than try to figure it out, we reverted back to the last theme backup we had which was 2.9.2

    It resolved everything except now there is a navigation issue. Like you, we only see first and last buttons – but comics are accessible through archives and their single post links.

    Let us know whether you resolved it!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Theme: Comicpress (Custom)] Navigation broken after update to 4.2.1’ is closed to new replies.