Support » Themes and Templates » Theme 2010 Weaver – Table borders (How to get them away completely?)

  • Does anyone know how you get rid of the borders (and other pre-settings) when using HTML tables in the theme “2010 Weaver”??? I just can’t get them away. The only table-entrys in the stylesheets I found in the file 2010style.css where all other design stuff is defined (as fonts etc.). There it’s written:

    #content table {
    border: 1px solid #e7e7e7;
    margin: 0 -1px 24px 0;
    text-align: left;
    width: 100%;

    Changing the values like this doesn’t help:

    #content table {
    border: 0px solid #ffffff;
    margin: 0 -1px 24px 0;
    text-align: left;
    width: 100%;

    Even using the white color #ffffff doesn’t help. The borders resist! Where do they come from?

    In the post entries I write in HTML section:

    <table style=”border: solid 2px #ffffff;” align=”left”>
    <td style=”border:none” width=”35%” valign=”top”>xx</td>

    Using that style=”border:..:” is so far the only way to avoid the borders. But it’s ugly and stupid to have to make every single td invisble.

    Can anyone help me? I’m searching since hours for the solution. Didn’t find it so far. Thank you.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Try using border:none;.

    Inserting border:none or border: none in the 2010style.css doesn’t help neither.
    Only using this in every single <td> helps but that’s not a good “solution”.

    I have the impression that there must be another place where some table-settings are fixed (not only in this 2010style.css or at another place). BUT WHERE??? Any ideas?

    Weaver 1.5 has 5 different table styles, including no borders. The table issue is difficult. Essentially, if you want to build your own style, pick the no border version, then add your own table style rules to the <HEAD> section, being sure to style every aspect – table, tr, td, th – and every option – border, margin, padding, etc. Styling tables seems to be one of the most difficult CSS challenges there is.

    Thanks, that’s very interesting. Could you please help me a little bit more? In which file do I find the table style settings – and how can I tell the 5 different table styles there are?
    A manual or something on the weaver homepage would be great! I’m already very happy with the theme 2010-Weaver – that would even improve it.

    try using border:none !important;

    and it will overrides all the css templates



    The following code in my header <style> worked for me. (You don’t need all this, just the border:none parts)

    #content table {border: none; margin: 0 -1px 24px 0;text-align: left;width: 100%;}
    #content tr th,#content thead th {border: none; color: #000000;font-size: 14px;font-weight: bold;line-height: 18px;padding: 2px 24px; background-color:transparent;}
    #content tr td {border-style:none; border-top: 0px; padding: 2px 24px;}
    #content tr.odd td {background: none;}

    Moderator Kathryn


    Automattic Happiness Engineer



    I cannot get rid of the table border in the 2010 weaver there. I have followed all of the above advice but to no avail. Would anyone be prepared to access my website and tell me what I am doing wrong? Ken Bird.



    kenbird start your own thread

    The whole table styling has been upgraded with more recent versions of Weaver. The newest Version 2.0 will be available here on soon, and the RC is available now at

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Theme 2010 Weaver – Table borders (How to get them away completely?)’ is closed to new replies.