Support » How-To and Troubleshooting » [Resolved] the_content remains empty on category pages

[Resolved] the_content remains empty on category pages

  • I’ve never experienced that problem before.
    Setup: custom theme, based on 2011 1.4.

    excerpt from the content.php:

    <div class="entry-content">
    			<?php the_content( __( 'Continue reading <span class="meta-nav">&rarr;</span>', 'twentyeleven' ) ); ?>
    			<?php wp_link_pages( array( 'before' => '<div class="page-link"><span>' . __( 'Pages:', 'twentyeleven' ) . '</span>', 'after' => '</div>' ) ); ?>
    		</div><!-- .entry-content -->

    this part is supposed to output the content on category and single post pages. It does so on single post pages, but on category pages, nothing. Checked the code several times. Same Problem in theme 2011.

    You can see the issue here:
    http://www.cad-helpdesk.de/sst/solid-edge – no content
    http://www.cad-helpdesk.de/sst/was-tun-bei-einem-netzwerkfehler.html – content displayed properly, by the same code

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Michael


    Forum Moderator

    Twenty Eleven should use content-single.php for single posts;

    waht is the full code of category.php of your theme?
    and the full code of content.php?

    please use the http://pastebin.com/ – see http://codex.wordpress.org/Forum_Welcome#Posting_Code

    what happens if you temporarily deactivate all plugins?

    I’m always designing my themes as minimalized as possible. That’s why i rip out everything i don’t need. In this particular case, i only use one content.php, no single, no page, nothing else. And content.php is almost the same as 2011. But, thanks for the hint with the plugins. Forgot to check that even though i know. Figured it out: activating simple like buttons leaves all the_content empty on category pages.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] the_content remains empty on category pages’ is closed to new replies.