Support » Plugin: BuddyDrive » the “zip” are corrupt because they are added 5 lines in the code.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author mrpritchett

    (@mrpritchett)

    Can you post the “five lines” please? I’ve never heard of this happening before. Can you try installing the plugin from the dashboard rather than downloading it?

    In practice, I have installed the plugin, the plugin works perfectly.
    I try to download an uploaded document, but the document is not recognized as a .zip.
    I have investigated and opening any .zip downloaded from the site through the plugin is corrupted by 5 lines in the code (open with notes ++).
    I’m sorry I do not write well.
    I would like to let you know …..
    try downloading a document and any attempt to open the .zip …. an error message will warn you that it is not a .zip. If you open it with winrar opens the .zip with all other software to unpack you fail. If you open the .zip with notes ++ you will find that in the code are placed 5 white lines (no writing), if these lines are removed the zip works perfectly.
    The .zip qualdo the load is perfect, but when the discharge is corrupt of these 5 white lines …. do not know why

    I created a fake user to make test the problem
    site: https://www.blender.it
    User: fake
    password: fake
    drive link: https://www.blender.it/gruppi/modelli-3d-scaricabili/risorse-condivise/#view/506558
    Direct link: https://www.blender.it/risorse-condivise/file/test/

    The .zip when the load on the site is perfect, but when I make the download is corrupt of these 5 white lines …. do not know why

    Plugin Author mrpritchett

    (@mrpritchett)

    The zip file is definitely corrupted. Unzipping the file for me results in an infinite loop of zip to .cpgz to .zip which is caused by corruption of the file that you compressed. BuddyDrive is not causing this issue from what I can tell as I am able to upload zip files, download them and unzip them just fine in testing. Have you tried testing with no other plugins installed/activated other than BuddyPress and BuddyDrive and on one of WordPress’s default themes? Please try this with your current file as well as try it with a new zip file. My guess is that either a theme/plugin conflict is occurring or perhaps your base file is corrupted. If you can test these things and then let me know the results I’ll be happy to continue to debug this issue with you.

    @blenderitalia

    Do you use a bp-custom.php file in your site?

    @atmojones
    Thank you,
    I’m sorry for the late response. I realized spaces in bp-custom.php. I have deleted these spaces and the problem is solved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘the “zip” are corrupt because they are added 5 lines in the code.’ is closed to new replies.