WordPress.org

Support

Support » Installation » [Resolved] the WP published system requirements contain several mistakes

[Resolved] the WP published system requirements contain several mistakes

  • Hi,
    Please can someone clarify the system requirements here:
    http://wordpress.org/about/requirements/

    It starts off saying:
    PHP version 5.2.4 or greater
    MySQL version 5.0 or greater

    But that:
    The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.

    OK, is this a typo or have the system requirements really stepped back to earlier versions of mysql and php? I’m guessing it’s a typo and the versions should be PHP 5.3 and Mysql 5.1

    And does that relate to the already released 3.1 or to the AS YET UNRELEASED v3.2?

    Side note to someone at the ‘company’ – come on guys! this is a core page and that sort of incoherent nonsense doesn’t look good and is just needlessly confusing!

    Ta.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I read it like.

    3.2
    PHP version 5.2.4 or greater
    MySQL version 5.0 or greater

    3.1
    PHP 4.3
    MySQL 4.1.2

    So your question was?

    I thought the question was pretty clear really – please will someone clarify the goddam system requirements.

    Thanks for your reply but your reading doesn’t make sense:

    We are currently at version 3.1 now so, as stated at the top of the page, the requirements are (currently):

    PHP version 5.2.4 or greater
    MySQL version 5.0 or greater

    …not php 4.3 mysql 4.1.2 as you said.

    Apart from the fact that mysql version 4.1.2 is like 8 years old, there are major differences between v4 and v5 mysql (as there are between php4 and php5). Added to which, my server has NEVER run mysql < v5 so it just doesn’t make sense that the versions would be 4.x.x

    My point remains that the published requirements are a mess and someone needs to clarify them.

    3.2 Is due to be released, so I suppose they’ve just been quicker editing the codex than in releasing the actual version. So with the current version, it’s 4.3 and 4.1.2 (minimum), as soon as 3.2 is available it is 5.2.4 and 5.0.
    (I hope this takes a while, since my host does not offer MySQL 5 yet.)

    Right now it says this on the requirement page:

    The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.

    The blog post, Are You Ready for WordPress 3.2?, says:

    As of 3.2, you’ll need to be running PHP 5.2.4 and MySQL 5.0.

    It looks to me like the requirements page contains incorrect info.

    how is it incorrect?

    As Roy has already pointed out,

    3.2
    PHP version 5.2.4 or greater
    MySQL version 5.0 or greater

    3.1
    PHP 4.3
    MySQL 4.1.2

    which is exactly what you just quoted.

    Oops. I read that twice and didn’t get it. Since the paragraph starts with “The requirmenets have changed as of WordPress 3.2” I was expecting to see the requirements for 3.2 and missed the part where it said WordPress 3.1. Thanks for pointing that out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] the WP published system requirements contain several mistakes’ is closed to new replies.