WordPress.org

Support

Support » Reviews » The worst I have seen

The worst I have seen

  • You need to provide your complete google credentials in order to place ads.

    I doubt whether this plugin can really show ads.

  • The topic ‘The worst I have seen’ is closed to new replies.