Support » Plugin: WordPress Landing Pages » The WordPress Landing Pages plugin requiresPHP version 5.3 or greater.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem – also on 5.4+

    Plugin Author David Wells


    We are using the standard version detection via PHP

    if ( version_compare( phpversion(), ‘5.3’, ‘<‘ ) )

    Can you guys run and make sure you are on a higher version?

    Try this as well

    Hi to all

    I do have the same problem – I am using PHP 5.3.5 – it is definitly greater than PHP5 (it shows me that PHP 5 is the Minimum Version I need)but maybe not higher than 5.3 :-). Where do we need to change this standard version detection to keep this plugin running?



    Plugin Author David Wells


    Can you verify your PHP version with ?

    Plugin Author David Wells


    The version check is within this file of the plugin:

    You can see we are looking for a version greater than 5.3 so 5.3.5 should pass. Perhaps its ignoring the third decimal though.

    Can you try changing the version number to 5.2 and seeing if that works?

    We had to disable 5.2 php users from using the plugin because of issues they were facing

    I had changed the Version check to 5.2 – but it still doesn´t work. I am using PHP Version 5.3.2-1ubuntu4.22.

    I used the phpinfo function – I guess it is that one you are using as Standard Version detection. I had also tried to put in the full php string for comparing – but it doesn´t matter.

    The plugin is starting but I can´t create any landing page cos the editor shows me only the title tag and nothing more. Could it be possible that this plugin doesn´t likes Javascript?

    I am using also a shop plugin named wpshopgermany. This is using also JavaScript. But on another way there are also javaScript stuff inside the wordpress core. Thanks for your help.

    I found out that your plugin doesn´t likes qtranslate plugin. I had deactivated this plugin and suddenly everything is working with landing pages plugin. So it isn´t an issue with that php Version.

    Why they do not like each other?

    Plugin Author David Wells


    Not sure we have had reports of qtranslate causing problems in the past as well.

    We can’t account for other plugins though its not scalable.

    Perhaps if you reach out to the qtranslate people they might have an answer

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘The WordPress Landing Pages plugin requiresPHP version 5.3 or greater.’ is closed to new replies.