Support » Fixing WordPress » The word “from” prevents me to create a post

  • Resolved mondayjournal

    (@mondayjournal)


    Hi

    Recently I’ve encountered a rather odd problem whenever I try to create a post. When I try to publish, save draft, or preview a post, it’d lead me to a 404 page. I found out that if the word “from” is written in the post, I can’t publish, preview, or even save the post.

    To make it more interesting, I found out that I can include the word “from” in the post if there isn’t any inserted link. So in order to create a post, I need to create one that doesn’t contain the word “from” or an inserted link since the combination of both prevents me from making any change to my post.

    However, my previous posts that contain both “from” and inserted links are fine and still can be accessed. It’s just happened when I try to create or edit a post. I’ve reinstalled and clean installed my WordPress, changed my theme to Twenty Sixteen, disabled my plugins, but to no avail. The problem still persists.

    I also found that another user shares the same problem and it seems that it hasn’t been resolved.

    Any help would be really appreciated.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Did you tried installing another version of WP (older or beta/RC).

    Also can try moving your webstie to another hosting for a moment. I think this can be server related

    Hi,
    did you install WordPress manually or by some kind of one-click-installer. They often add custom jQuery code, or Must Use Plugins (check if you have ‘mu-plugins’ in ../wp-content folder)

    • This reply was modified 4 years, 6 months ago by mihannsell.
    Moderator cubecolour

    (@numeeja)

    This is a strange issue, and not one I have heard of before.

    Please post a link to your site as there might be a clue in the page source.

    I can suggest some basic troubleshooting measures that might help pinpoint the cause of the issue to get closer to a resolution.

    If default ‘non-pretty’ permalinks are set, Go to settings -> permalinks in admin and set a permalink. Check whether the issue still occues. Otherwise try pressing ‘save’ on the permalinks admin page to resave the permalink setting before testing.

    The next thing to investigate is whether an installed plugin is somehow causing the issue by temporarily deactivating all plugins and testing whether the issue still occurs.

    Then investigate whether your theme might be causing it by switching to a default (twenty-something) theme and testing again.

    Thread Starter mondayjournal

    (@mondayjournal)

    Hi palmiak, mihannsell, and cubecolour

    Thank you for the reply.

    I didn’t install an older or beta version of WordPress. I only use the recent one and always update it. Unfortunately, I don’t have any plan to change my hosting provider, so I can’t test whether changing hosting may fix the problem. But I agree that perhaps the server may contribute to the problem.

    My WordPress was installed by my hosting provider and when I reinstalled it, I uploaded the files manually using FileZilla. I have checked the folder and it doesn’t contain the “mu-plugins” file.

    This is my website: http://monday-journal.com/

    I have changed the permalink to “Post-name”, disabled all of the plugins, and switched the theme to Twenty Sixteen, but the issue still occurs. I start to suspect that the configuration of the server may cause it.

    Thank you again for taking the time to help me.

    Moderator cubecolour

    (@numeeja)

    I can see several instances of the word ‘from’ on the page and the posts seem to load OK, so I’m still not sure what the cause of the 404 on publishing might be. I would suggest asking your host’s support in case it is something due to the server configuration as you have eliminated the theme or plugins being the cause.

    If you don’t want to change hosting just try to install it on localhost (wamp or lamp).

    But it looks like hosting related.

    Thread Starter mondayjournal

    (@mondayjournal)

    Hi

    I want to give an update about the problem that I have.

    I’ve contacted my hosting provider and they told me to try disabling ModSecurity in Cpanel. And it actually fixed my problem! I can edit and create a post with both inserted link and the word “from” again. However, I can only do it if ModSecurity’s disabled. If it’s enabled, the problem occurs again. So it seems that this’s only a temporary solution. But I think that’ll do for now as I’m planning to change my hosting provider now.

    Thank you everyone for helping me.

    • This reply was modified 4 years, 5 months ago by mondayjournal.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘The word “from” prevents me to create a post’ is closed to new replies.