WordPress.org

Forums

Social Media Feather - lightweight social media sharing and follow buttons
[resolved] The word "by" appearing in post excerpts (8 posts)

  1. kirkbyboy
    Member
    Posted 1 year ago #

    I'm getting the word - by - appearing on my blog page http://www.kirkbymoorside.info when there are posts which just have posters ie no text written. Where there is text then the "by" doesn't appear if there is sufficient text - if not it appears at the end of the excerpt.

    When I deactivate Social Media Feather this disappears - any thoughts anyone?

    Thank you.

    http://wordpress.org/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    I'm assuming your theme is doing something odd. Try and go in General preferences and change "full post" to "excerpt" or maybe see if the theme has settings to control this behaviour.

  3. lagdonkey
    Member
    Posted 1 year ago #

    I actually came here looking for a solution to this EXACT problem, but found it was because the "show credit" option was checked in the settings page. I think this was what OP was referring to, hope it helps.

  4. pacquills
    Member
    Posted 1 year ago #

    In your dashboard go to settings -> social media, and uncheck 'show credit' and it will appear like on the footer here: techriffs kenya using the same plugin.

  5. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    Note that this is not a complete solution. The word "by" should only appear when the icons also appear. If it's there without the icons it means your theme is doing something unorthodox such as running the_content filter on excerpts which is something it shouldn't do.

  6. amorgwrites
    Member
    Posted 1 year ago #

    I'm getting the same problem, except that the excerpts are preceded with "Share this:" which is the text I inserted in the Share Prefix Markup box. So obviously, my theme (Magazine Premium by Bavotasan), is doing something it shouldn't be. As a complete noob, could you give me the quick 1,2,3 on how to resolve use of the_content filter on excepts problem?
    Tx.
    http://www.andymorganwrites.com

  7. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    Probably the theme is making a call to add_filter('the_excerpt', ...) searching for that and then making a call somewhere to remove_filter should possibly fix it, but might break some other things in the theme. It's best if you ask the theme developers.

  8. bt7411
    Member
    Posted 1 year ago #

    Hi, I've got the same problem as amorgwrites: "Share This" appears in excerpts with no icons. See http://scubacat.com/ (half way down "Other Recent Posts"). I've been in touch with Solostream who make the Radiance theme I'm using and they say they are using the standard way of calling a post excerpt. Here is their code:

    /*-----------------------------------------------------------------------------------*/
    // Function to get the post excerpt
    /*-----------------------------------------------------------------------------------*/
    function solostream_excerpt() {
    	if ( get_option('solostream_post_content') == 'Excerpts' ) { ?>
    		<?php the_excerpt(); ?>
    		<p class="readmore"><a class="more-link" href="<?php the_permalink() ?>" rel="nofollow" title="<?php _e("Permanent Link to", "solostream"); ?> <?php the_title(); ?>"><?php _e("Continue Reading »", "solostream"); ?></a></p>
    	<?php } else {
    		the_content(__("Continue Reading »", "solostream"));
    	}
    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic