Support » How-To and Troubleshooting » the word ‘Array’ is appearing everywhere in the dashboard

the word ‘Array’ is appearing everywhere in the dashboard

Viewing 15 replies - 16 through 30 (of 42 total)
  • @boudreaux:

    Actually, I am on DreamHost and I have PHP 5.x/MySQL 5.x so our versions are different, but the bug with the ‘array’ I saw on your blog really puzzles me… 🙂

    Anyone any help on that?…

    WP 2.2 is supposed to run fine on PHP 4.3.x &
    MYSQL 4.0.x, right? So why in this case there’s the word ‘array’ all over the place and the blog is not working?…

    seems nobody can help us… 🙁

    I’m having the same problem, plus I cannot post anymore 🙁

    Anybody opened a ticket for this yet?

    Rel= http://wordpress.org/support/topic/118895

    My Sys=
    – Upgrade from version 2.1.3 to 2.2
    – Apache/2.0.53 (Linux/SUSE)
    – MySQL 4.1.10a
    – PHP 4.3.10
    – Register globals = No

    I’ve been seeing the error that boudreaux cited:

    Warning: Illegal offset type in /home/michae02/public_html/michaelboudreaux.com/wp-includes/cache.php on line 125

    I always install locally on my PPC mac before i send it up to my server. WP2.2 works on the mac, but not on the remote. Both are running apache 1.3.33, both have the same mysql version, but the thing that’s different are the mysql and PHP versions

    local:14.12 remote: 12.22

    local: 4.4.4 remote: 4.3.0

    That’s a pretty big gap on mysql and one major release on PHP.

    One more data point. I tarr’d up the WP install and put it on another hosting account I have and things worked! Their PHP / mysql pair was the following:

    [rootbeer]$ mysql -V ; php -v
    mysql Ver 14.12 Distrib 5.0.16, for pc-linux-gnu (i386) using readline 5.0

    PHP 4.4.4 (cgi) (built: Nov 7 2006 13:14:18)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2006, by Zend Technologies
    with Zend Optimizer v3.2.2, Copyright (c) 1998-2006, by Zend Technologies

    So that would seem to point that on my current host the PHP and or MySQL are the problem. I think that the minimum requirements need to be re-evaluated for 2.2.

    This seems to be an Zend Optimizer problem. Disabling Zend (my version is 2.5.10) did remove the issue for me (together with others). I’ll report if upgrading the Zend optimizer to the latest version will do the trick.

    Confirmed and upgrade to php 4.4.7 and zend optimizer 3.2.8 solved the issue described.

    The combination php 4.3.10 and Zend Optimizer 2.5.10. did not work.

    Is it possible to turn off Zend Optimizer via .htaccess?

    So, if we need the version of PHP to run WP is 4.4.7 for normal, then the official requirement is have problem…

    Adding this trac ticket for information–seems PHP 4.3.10 and Zend 2.5.10 are being used by Dennis’s client.


    I upgraded from:
    PHP version 4.3.11
    MYSQL version 4.0.27-standard


    PHP version 5.2.1
    MySQL version 5.0.27-standard

    and this fixed the issue.

    I too have the same problem and I dont really want to go through all the upgrading so which version of wordpress works with mysql 4?

    more having trouble here too


    I updated from WP 2.1 to 2.2, but it seems the version of PHP on my shared server (4.3.11) isn’t compatible with some of the changes made in the 2.2 release.

    I was brave, delved into the WP code, and was able to fix some of them, enough to have the blog be somewhat functional ,but at this point I’ve given up and I’m hoping WP will release a fix soon. (I don’t feel like fixing the Widget Admin JavaScript!)

    Anybody have any idea what is the REAL minimum requirements for WP 2.2 are?


    ‘Array’ showing up all over the place on the admin for WP.
    It seems that these are caused by uninstantiated fields of an object being printed out. A var_dump() of these uninstantiated fields returns Array(0){}. There’s probably a lot of these lying around the WP interface, but I fixed some of the most important ones that were preventing me from publishing posts and chaning viewing the Users admin page.

    Illegal offset type errors on the sidebar of my blog.
    These were caused by a similar problem. Uninstantiated paramaters in certain functions in cache.php were not being assigned the default value; instead they were being read as array, thus the Illegal Offset Type error (array vars can’t be used as keys)

    So now I don’t have those sidebar erros on my WP 2.2, and I can also publish. BUTT the Widgets admin doesn’t work because of some JS errors that I don’t really want to figure out.

    Or maybe I should….
    Anywho, if someone does, please let me know! Also if you’d like the fixes I made just let me know.

    I saw the ticket closed, the problem will not fix forever, and I can’t upgarde the WP to 2.2…

    So, I will consider change to another blog system…

    I have the same problem how can I solve it?

Viewing 15 replies - 16 through 30 (of 42 total)
  • The topic ‘the word ‘Array’ is appearing everywhere in the dashboard’ is closed to new replies.