Support » Plugin: Yet Another Related Posts Plugin (YARPP) » The used table type doesn't support FULLTEXT indexes

  • Resolved Viktor Nagornyy

    (@viktorix)


    Below you’ll see the error I’m getting. The site is hosted on Azure websites hosting (win server). Any help getting through this?

    ———————————————————————–
    WordPress database error: [The used table type doesn’t support FULLTEXT indexes]
    ALTER TABLE wp_posts ADD FULLTEXT yarpp_title ( post_title )

    WordPress database error: [The used table type doesn’t support FULLTEXT indexes]
    ALTER TABLE wp_posts ADD FULLTEXT yarpp_content ( post_content )

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

Viewing 10 replies - 1 through 10 (of 10 total)
  • markfarrar

    (@markfarrar)

    I’m getting a similar error on a WP v3.5.1 blog hosted on HostGator:

    [22-Feb-2013 23:00:57] WordPress database error The used table type doesn’t support FULLTEXT indexes for query ALTER TABLE wp_posts ADD FULLTEXT yarpp_content ( post_content ) made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), include(‘/themes/socrates/single.php’), the_content, apply_filters(‘the_content’), call_user_func_array, YARPP->the_content, YARPP->display_related, YARPP->enforce, YARPP->activate

    Plugin Author mitcho (Michael Yoshitaka Erlewine)

    (@mitchoyoshitaka)

    @viktorix: thanks for bringing this up. I should do a better job checking for FULLTEXT index support before trying to add it… I’m unfortunately not sure how to do so… will have to read up a bit.

    In the mean time, YARPP will continue to work without those fulltext indices, but you will have to lower the “match threshold”. Go to screen options > display “relatedness” options, then lower the match threshold to 1 or 2 and save.

    @markfarrar: do you know what kind of tables or databases your hosting uses? MySQL servers? MyISAM table type?

    Hey Michael,
    Thanks for quick reply. The problem is twofold. Those errors do not go away in the admin, and two – on the frontend right before the_content is being displayed it outputs a bunch of database variables and stuff. Is it possible to simply disable that feature to be able to use low relatedness feature?

    markfarrar

    (@markfarrar)

    Michael,

    The tables on my WP database for this site appear to be a mixture of InnoDB and MyISAM, with the single YARPP table being a MyISAM.

    Thanks,

    Mark

    Plugin Author mitcho (Michael Yoshitaka Erlewine)

    (@mitchoyoshitaka)

    @markfarrar the question is what type of table wp_posts is. You want that one to be MyISAM.

    @viktorix I’m going to try to do some more testing to make this handling a bit better in a later version. Sorry about that.

    Michael,

    It seems as though wp_posts is an InnoDB table.

    Can this be changes to MyISAM, or am I stuck with this problem?

    Thanks again,

    Mark

    @markfarrar yes, you can change your wp_posts table to MyISAM and you’ll be all set.

    Michael,

    Thanks – that seems to have solved it.

    Best wishes,

    Mark

    Mitcho, I’m also having this same issue on “wp_posts”, but because of the size of the website and it’s traffic I cannot run MyISAM because of it’s limitation. InnoDB is the best choice (for any high traffic site).

    How can we go about fixing this?

    Thanks Mitcho!

    Renan.

    Plugin Author jeffparker

    (@jeffparker)

    Hi Renan. You can still use InnoDB but you will only be able to take advantage of tags and categories, not title or body content.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘The used table type doesn't support FULLTEXT indexes’ is closed to new replies.