Support » Fixing WordPress » The uploaded file exceeds the upload_max_filesize directive in php.ini.

  • silver2570

    (@silver2570)


    hello there,

    I have been struggling with product images not uploading

    i have search everywhere and tried all solutions with no success

    I have increased images upload limits from my cpanels still the same message comes up. I have exhaust all options I found. This is one of my last hopes.

    I have sent a message to my host to check out things from their side they might have done an update that has affected something.

    I have three websites with the same host, the images that are not uploading on one site are uploading fine with no trouble on the site that need these product images. I have deactivate all plugins still the problem exists.

    your kind help and support is highly appreciated

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • kjodle

    (@kjodle)

    First, can you verify what the upload_max_filesize size is in php.ini? Upload a php_info() file to your server and view it in your browser if you don’t.

    Secondly, how large are these image files? The smallest I’ve ever seen upload_max_filesize set to is 2MB; if you’re running an ecommerce site, I imagine your images are smaller than that for seo purposes.

    silver2570

    (@silver2570)

    thank you for your response

    The following settings below are from the php.ini

    Home Directory settings are as follow:

    max_execution_time 30

    memory_limit 512m

    post_max_size 8m

    upload_max_filesize 200m

    The following settings are for the domain having the trouble

    max_execution_time 300
    memory_limit 256m
    post_max_size 64m
    upload_max_filesize 300

    when i did the change to the settings I changed only the settings on the domain with the issue i did not touch the directory I can see the settings are not the same i dont know if that contribute to the problem or not

    many many thanks for your kind support

    I will check the sizes of the images then get back to you

    kjodle

    (@kjodle)

    You are missing an “m” on this line:

    upload_max_filesize 300

    It should read:

    upload_max_filesize 300M

    Try making that change and seeing what happens.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘The uploaded file exceeds the upload_max_filesize directive in php.ini.’ is closed to new replies.