Support » Fixing WordPress » The uploaded file could not be moved to .

  • I recently updgraded from 2.0 to the new 2.0.1 and somehow I must have done something to get this error message when I try to upload a picture:

    The uploaded file could not be moved to .

    Can someone let me know what its referencing and what/where I need to fix?

    Thanks so much

Viewing 15 replies - 1 through 15 (of 26 total)
  • I also have the same problem on 2.0.1. It sounds liks it’s being uploaded to a temp directory but then can’t be moved from there – perhaps it’s a security feature of the server? (I’m on Apache.)

    Can you have a look at your fileupload_dir entry in the admin panel ? (options -> misc)
    Is that set properly ?

    Well, it began working just after you posted. I can now upload okay – except the “delete” function doesn’t work. I think it might be the permissions set on the uploaded files? – apache owns them whereas I own the rest of the files in the WP directory.

    Getting the same with 2.0.1. File upload directory is wp-content/uploads with permissions 777. Doesn’t make any difference whether the box dividing uploads into years and months is checked.

    I also experience the mentioned upload problem. However, I think it worked fine before moving the location of my wordpress installation to a sub directory; the url changed from to What could have gone wrong?

    How odd, I was certain I had set write-permission on the uploads-folder, but found that I hadn’t. After setting write-permission on the wp-content/uploads folder it works fine.

    I got past my uploaded file could not be moved error by going into server via ssh, and noticed that the owner of one of the folders in the upload area was set to group and owner as apache instead of the account user. When I changed group and owner on this folder, I could then upload images. So even though I had persmissions set to 777, the group and owner still needed to be correct.


    Upon upload I kept getting:
    “The uploaded file could not be moved to .”

    I had just finished migrating WP 2.01 from one server to another. I had wp-content/uploads permissions set correctly as 0777. The fix was:

    (1) I copied my uploads folder (and renamed it)
    (2) I then deleted wp-content/uploads
    (3) I then recreated wp-content/uploads (mkdir)
    (4) I then set permissions on wp-content/uploads (chmod 0777)
    (5) I then copied all the folders/content I copied in step 1 –> the folder created in step 4

    Voila. Works again, I can upload.

    I had no contents directory. I created it. Set it to 0777 and I have the same problem. Running 2.0.2.

    The complete upload error: “The uploaded file could not be moved to .”

    Any more suggestions?

    I had the same problem with WP 2.0. I just made the following folders 777 and it now works:


    Thanks for your help.

    Does the wp-contents folder have to be 777 as well? And does the file being uploaded have to have its permissions set to 777?

    I had the same situation (new server, no uploads permitted, same error reported) and followed the [delete] [re-create] [assign permissions] process and it worked fine for me as well.

    I did it slightly more easily than copying and re-naming, though. I opened up File-Zilla, connected to the server that my blog is on, deleted the naughty [uploads] folder completly, re-uploded the folder from my local disk, then drilled down the most recent branches of the tree, setting permissions of 777 as I went.

    Pity it has to open the door so wide to the world though.

    I have the same problem uploading (The uploaded file could not be moved to) I read the the above post.. i Have wordpress 2.0…Right now i have ws-content/uploads/777 in the section Miscellaneous/options when i also created a folder for uploads and sub dir for 777….though i still get the error when trying to upload…

    anyone can help

    max: If the parent folder is 777 (actual directory where file is being created) and you still get an error, it’s likely that the file may already exist there. Check with ftp?

    Another issue is that some configurations require ANOTHER subdirectory for thumbs (such as wp-content/uploads/2006/07/.thumbs). Check that too?

    Thanks yosemite though i still have problems…maybe i’m not understanding you right..can you give me step by step… I type wp-content/uploads/2006/07/.thumbs Miscellaneous/options section… And i created folders: 2006,07,.thumbs in my FTP. though i got the error

    Unable to create directory /home/nichols/public_html/cashbizonline-com/wp-content/uploads/2006/07/. Is its parent directory writable by the server?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘The uploaded file could not be moved to .’ is closed to new replies.