WordPress.org

Support

Support » How-To and Troubleshooting » "The uploaded file could not be moved to wp-content/uploads/2013/10."

"The uploaded file could not be moved to wp-content/uploads/2013/10."

  • neahfeald

    @neahfeald

    Hello,

    Last night, media upload worked just fine. This morning, it’s suddenly broken. I have googled the problem and read through several similar cases. I have tweaked the permissions in FTP to everything between and including 744 and 777, but the error persists. I have also deactivated all the plugins, which did not solve the problem either.
    I uploaded a picture to the folder manually (through FTP), it is not seen by the media library in the WP dashboard. I have also noticed that the already uploaded images in media library become unavailable unless the permissions of the upload folder is set to 777, which is a well known security issue.

    How do I fix is so that I can upload images again and keep my images available with a safer permission setting?

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

    neahfeald

    @neahfeald

    Update for those with the same problem:

    Found temp fix on this website, turns out I can upload an image when I uncheck “Organize my uploads into month- and year-based folders” IF the uploads folder is set to permission 777 (step 14). However, the error in media library comes back immediately after lowering the permissions to 775 and the images on my website stop working if I lower it to 754.

    neahfeald

    @neahfeald

    766: images don’t work on the website & media upload doesn’t work
    767: images on website work, upload works, however security issue as this opens the public permissions fully (so doesn’t solve the 2nd bit of my problem as I can’t leave it on this permission).
    775: images work, upload doesn’t work (as stated in the above message)
    777: same as 767

    *note: this only works this way if ” Organize my uploads into month- and year-based folders” is not checked in media settings. If I check this option then uploads fail on 767 & 777 as before.

    esmi

    @esmi

    Forum Moderator

    What version of WordPress are you using?

    neahfeald

    @neahfeald

    Version 3.6.1

    esmi

    @esmi

    Forum Moderator

    Sorry but you’ll need to speak to your hosts about this one.

    I’ve got the exact same problems after moving my WordPress site to a different host. I’m using version 3.5.2 by the way and I have exactly the same issues with the permissions that neahfeald explained above.

    My host has been looking at this, perhaps someone can tell us if they’ve had the same issues, how their host fixed it, it might help them get there quicker?

    Thanks for the help

    Ok, fixed this, make sure you did not place any folders in the “uploaded” directory, then, (i know it sucks) upload One by one…. I also changed permission via FTP to 777…..
    all this worked. I am now succesfully uploading photos to my /uploads/2013/10 where the error was. Also, as long as your “upload bar” says “crunching” ignore any error, it’s still in the media folder.

    Had the same problem and solved with:

    sudo chown www-data uploads/
    sudo chmod 755 uploads/

    where uploads is a folder in wp-content.

    The owner of upload folder has to be www-data.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘"The uploaded file could not be moved to wp-content/uploads/2013/10."’ is closed to new replies.