Support » Fixing WordPress » The uploaded file could not be moved to wp-content.

  • mandykayphotography

    (@mandykayphotography)


    Hello,

    As of last night (6/26) I can not upload any images to any galleries anywhere in my PP4/WP site. Not to galleries within pages, on the main post page, directly to the media library, etc. I get this same message with every single attempt: The uploaded file could not be moved to wp-content/uploads/2013/06.
    I have researched your other threads, and others are having this problem too. I tried changing permissions and that did not work. I called my host, godaddy, and they troubleshot for over an hour, on two separate phone calls. They looked into permissions issues as well and said it wasnt an issue there. They say the problem is in WP. I feel like i’ve exhausted all options, so looking for what I can do next. Please help!

    Thank You! 🙂

Viewing 15 replies - 1 through 15 (of 37 total)
  • WPyogi

    (@wpyogi)

    Forum Moderator

    Have you tried deactivating all plugins and switching to the default theme?

    mandykayphotography

    (@mandykayphotography)

    A little scared to switch to the default theme because my whole PP4 layout is a custom one. ANd I just dont know how to reinstall it myself after this test. I can deativate the plugins though, so I will try that. Godaddy, after 2 hours and 2 reps….tried a million tests and the thing they thought it might be was that I had way too many photos in each folder, apparantely WP makes 2-4 copies of each original I upload, so I went in filezilla and deleteted over 8,000 files. Now when I try uploading images, I dont get the error message, but I get a red ‘x’ on where the thumbnail is and there is no photo displayed. Any ideas….I will try to deactivate plugins now too. Thanks!

    WPyogi

    (@wpyogi)

    Forum Moderator

    Switching themes is standard troubleshooting – all you do is click activate on the theme. But if it’s a space issue, the theme probably isn’t the issue.

    Either way, I’d suggest that you back up your site and database before embarking on these steps.

    mandykayphotography

    (@mandykayphotography)

    Deactivating plugins didnt work, so….if I activate on the default theme….I can go back and deactivate it after and the one I have up now will come back?

    mandykayphotography

    (@mandykayphotography)

    So….I actually am in the default theme. It just says I’ve made customizations to the default. Thats what the graphic designer did.

    WPyogi

    (@wpyogi)

    Forum Moderator

    Your site is using ProPhoto – that’s not the default WP theme – which is twentytwelve.

    mandykayphotography

    (@mandykayphotography)

    Where do I access that area then? And once I activate the default, how do I get the customized ProPhoto one back on?

    mandykayphotography

    (@mandykayphotography)

    Ok I found where to activate twentytwelve. Im just scared to, lol. Once i’ve done that, do I need to deativate plugins along with that? And after i’ve done all that, I can reactivate plugins AND my theme? Reactivate theme in the same place I activated the twentytwelve theme? Sorry….not my strongest area :p

    WPyogi

    (@wpyogi)

    Forum Moderator

    See: http://codex.wordpress.org/Using_Themes#Selecting_the_Active_Theme

    Do you have a full back-up of your site?

    mandykayphotography

    (@mandykayphotography)

    I’m backing it up now, its about 75%. Going to email me the backup.

    mandykayphotography

    (@mandykayphotography)

    I also have the full zipped file that the designer sent over when she did everything…is that helpful?

    WPyogi

    (@wpyogi)

    Forum Moderator

    That’s good if you have to reinstall the theme, yes. But as I said above, if it’s a space issue, the theme probably is not the problem. I’m also not sure that deleting images was a good idea :/ …

    Still, switching themes will help narrow down the problem(s).

    esmi

    (@esmi)

    Forum Moderator

    I get this same message with every single attempt: The uploaded file could not be moved to wp-content/uploads/2013/06.

    Is that the complete error message or is there more?

    mandykayphotography

    (@mandykayphotography)

    esmi, this is the whole of what it was saying:

    “IMG_0879 L.jpg” has failed to upload due to an error.
    The uploaded file could not be move to /home/content/11/7829811/html/wp-content/uploads/2013/06

    It isnt saying that now though. It seems to upload images, but they have the red ‘x’ where the thumbnail should be and then wont display or anything.

    esmi

    (@esmi)

    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘The uploaded file could not be moved to wp-content.’ is closed to new replies.