Support » Plugin: WP User Frontend - Membership, Profile, Registration & Post Submission Plugin for WordPress » The upload image button on iOS Safari only does not work

  • Resolved oyooyo

    (@oyooyo)


    Hi All,

    Image uploading is not possible on the user posting screen. That is a problem only with iOS safari.
    Clicking the button does not respond.
    Please help me, thank you.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Mahbubur Rahman Rabbi

    (@rabbii)

    Hello @oyooyo,

    Could you please try with Safari on another device? Let me know the updates.

    Thanks

    Hello @rabbii

    I tried Safari on another device. For PC and android, it worked normally in Safari.
    Only Safari on iOS will not work.

    Thanks

    May I ask one more?
    Do you know if this is a bug in iOS or a plugin?

    Thanks

    Hi @oyooyo,

    We are still investigating this issue and not sure if it’s an issue from plugin or iOS devices. Will update you here soon as we get to figure this out.

    Thanks

    Hi @rafsuntaskin

    We are waiting for the results of the investigation.

    Thanks

    Hi @oyooyo,

    Can you please tell us the device model and the plugin version where you found the issue?
    Our Testers were failed to reproduce the issue in iPhone 6 and iPhone 7.

    Thanks

    Hi @rafsuntaskin

    The plugin is version 2.8.6
    The problematic devices are iPhone 5s, iPhone 6plus, iPhone 6s.

    Thanks

    Is there a possibility that the theme you are using and the plugin are not compatible with each other?
    The URL you are using:https://crasii.com

    Thanks

    Can you please provide the URL of the FORM where you are facing the issue?

    Login is required to display the URL of the form faced the problem.
    Please log in with the test account below.

    https://crasii.com/user-post/
    メールアドレス(login):sewa906@svk.jp
    Password:usertest

    Please press “ログイン” to login after input.

    Thanks

    On my site, I tested with iPhone 5s, Safari, iOS 9.3.5
    File Upload and Image Upload: Both works fine.

    I suspect it could be a bug with latest iOS update. ?

    If that could be of any help, here’s what I created in my CSS for these file selectors:

    ul.wpuf-form li .wpuf-fields a.file-selector,
    a.button.file-selector,
    a.button {
        text-decoration: none !important;
        line-height: 20px !important;
        height: inherit !important;
        font-family: inherit !important;
        font-size: 15px !important;
        padding: 6px 14px 7px 14px !important;
        margin-bottom: 0.5em;
        color: #FFF !important;
        text-shadow: none !important;
        background: #EB7200 none no-repeat !important;
        border: solid 0px #eb7200 !important;
        border-top: 0px solid transparent !important;
        border-bottom: 0px solid rgba(0,0,0,.1)!important;
        -moz-border-top-colors: none;
        -moz-border-right-colors: none;
        -moz-border-bottom-colors: none;
        -moz-border-left-colors: none;
        border-image: none;
        box-shadow: none !important;
        font-style: normal !important;
        font-weight: bold !important;
        vertical-align: baseline !important;
        position: relative !important;
        border-radius: 3px !important;
        -webkit-border-radius: 3px !important;
        -moz-border-radius: 3px !important;
        -ms-border-radius: 3px !important;
        -khtml-border-radius: 3px !important;
        -o-border-radius: 3px !important;
    }
    
    ul.wpuf-form li .wpuf-fields a.file-selector {
        display: inline;
        cursor: pointer;
        -webkit-appearance: none;
        white-space: nowrap;
    }

    Hi @anticosti

    The CSS that you taught did not solve the problem.
    I tried on all the devices from iOS 9 to 11, but all problems occurred.

    iPhone 4s, Safari, iOS 9.3.5
    iPhone 5s, Safari, iOS 11.2.6
    iPhone 6plus Safari, iOS 11.2.6
    iPhone 6s, Safari, iOS 10.3.3

    On the screen where the problem occurred, if you select “Open in background” after long press of the upload button, It works normally on the opened tab.

    Thanks

    I found another browser that is experiencing problems. The same problem occurred not only in sarari but also in iPhone Opera.

    It works normally with iOS firefox and Chrome.

    • This reply was modified 1 year, 1 month ago by  oyooyo.
    julianruizsa

    (@julianruizsa)

    I’m having the same issue, any idea why it happends or how to solve the problem?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘The upload image button on iOS Safari only does not work’ is closed to new replies.