• I had this issue reported a few month ago. Might be a different cause. Anyway there was an fix in the update and the uploads worked again.
    Version 5.38.12 now here and the uploads are again broken.
    it starts and uploads the file, but when it should start to import, it stops with the response “Upload failed”. Why is this simple feature so inconsistent? (And yes the csv files are correct)

    • This topic was modified 3 months, 1 week ago by mike8040.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support pistachio6321

    (@pistachio6321)

    Thanks for reporting this issue.

    Could you please share steps to reproduce it and a screenshot illustrating the error?

    Thread Starter mike8040

    (@mike8040)

    Hello there, thanks for heading over. Please see the screen cap:
    https://ibb.co/3N0fwRC

    There are no error logs that I could find. On further testing on the staging,it looks like that when Memcached is active the import fails. Deactivating Siteground Memcached and the imports work again.

    • This reply was modified 3 months, 1 week ago by mike8040.
    Plugin Support pistachio6321

    (@pistachio6321)

    Thanks for providing additional information. Ideally, you should not enable caching for admin pages because it can break functionality of plugins.

    Thread Starter mike8040

    (@mike8040)

    Sure I’m aware of that but that is the SG Optimizer where you can’t do anything and its said to be working out of the box. I have it in conjunction with WP Rocket according their setup. I can install and upload other data without issues. A few month ago I reported a similar issue and you guys provided a fix in an update and all was fine again. Now something is off again.

    Plugin Support pistachio6321

    (@pistachio6321)

    Please enable WP debug log and import reviews again then check if there is any error in the log file. If it has, please share the error log with us. We will try to investigate how ‘SG Optimizer’ breaks import of reviews.
    https://developer.wordpress.org/advanced-administration/debug/debug-wordpress/

    Thread Starter mike8040

    (@mike8040)

    To be clear I’m not a fan of one button do it all solutions as they never work. “SG Optimizer” is just activating Memcached and not doing anything else other than purging Ngix after WPRocket instruct it too. They are linked.
    Memcached shouldn’t break the upload or the writing in the tables if done correctly.
    I’ve done what you asked for and this is the only entry after a failed upload:

    [08-Feb-2024 02:24:25 UTC] PHP Notice:  Undefined variable: ivole_language in /home/customer/www/xxxx/public_html/wp-content/plugins/customer-reviews-woocommerce/includes/import-export/class-cr-background-importer.php on line 278
    
    • This reply was modified 3 months, 1 week ago by mike8040.
    Plugin Support pistachio6321

    (@pistachio6321)

    Thanks for sharing the error log. This issue should be fixed in the version 5.39.1. However, the problem with ‘SG Optimizer’ might still remain. Please test and let us know the results.

    Thread Starter mike8040

    (@mike8040)

    Hello, thanks for the update but there has nothing changed with that issue. Update failed and no debug log or php error log. This upload function just says “Upload failed” without any hint whatsoever. The php warning is at least gone from my prior post

    • This reply was modified 3 months ago by mike8040.
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.