Support » Themes and Templates » The theme is missing the style.css stylesheet

  • Resolved ClintonLee83


    I am unable to install a theme using both wordpress upload and FTP.

    When I upload the zip file to WordPress via “install themes”, I get an error message:

    The package could not be installed. The theme is missing the style.css stylesheet.

    Theme install failed.

    I tried to unzip the file to my desktop and upload the theme via Filezilla to “/wp-content/themes”. But after a successful upload, when I go back into my wp-admin, the theme doesn’t show up under my “manage themes”

    The style.css is in the top folder for the theme.
    Here’s the style.css for the theme (no white space preceding)>
    Theme Name: Bluelight
    Theme URI:
    Description: Bluelight | 2.0 Business or Individual Portfolio
    Version: 2.0
    Author: Mike McAlister
    Tags: bluelight, themeforest bluelight, template

    This is only the beginning of the stylesheet.

    Any idea’s for a fix?

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you have a copy of the full style sheet on your desktop ..just try ftping that into the /bluelight/ theme directory.

    I just tried to upload only the stylesheet to the bluelight folder in my themes directory but still no luck 🙁 this is so frustrating.

    I’m an idiot! I’ve never installed a Theme Forest theme before.

    I found the fix here,

    I’m still not sure why it didn’t load properly from FTP after unziping, But at least this post might help people in the future.

    Thank you Dragonsjaw!

    I had a similar problem to that originally reported by ClintonLee83. After downloading style.css from a working WordPress child theme, editing it on a Windows PC and then uploading back to the server… the theme disappeared from the wp-admin ‘Appearances’ panel! The parent theme was shown as the active theme.

    The child theme really was there, and could even be seen in a browser with a direct URL like [home_url]/wp_content/themes/[theme]/. But WordPress refused to recognise it.

    The solution was to edit style.css in Notepad++ and save it in Unix format (newline rather than CRLF). After that, the theme appeared as an extra theme and could be activated.

    Maybe WordPress does not recognise a theme folder unless it can (a) find a style.css or equivalent file, and (b) recognise something in the file. If so, step (b) did not work in my case until the carriage return characters were removed. YMMV.

    i got the same problem like ClintonLee83

    thanks for the solution Clinton 😀

    I had a siliar issue with a different theme. Check out the following solution:

    1. Unzip the theme on your desktop
    2. Check out the unzipped folder.
    3. In my case, there were 3 subfolders and not any file in the main folder.
    4. Actually, all the files (needed for the wordpress inslation to recognize the theme ) were in a subfolder.

    So, I realizes that these files, should not be in the subfolder, but in the main folder. So, here’s what I did:

    1. Uploaded the zip to my hosting account, to wp-content—>themes;
    2. Unzipeed;
    3. Moved the all the files and folder (all files, including style.css) from the subfolder to the main foldeer of the specific theme;
    4. Went into the wordpress cms under manage themes tab;
    5. The theme was recognized.

    Hope that I helped. Cheerz.

    Thank you – I’ve just had a similar problem but the subfolders won’t let me extract the files up to the main folder for some reason….any advice>?

    to wchvintage: might be a clash of folder names; if so, rename your folder and try again – if it still fails, rename it back again and ask your hosting company for support. Good luck!

    thank you very much – i managed to figure out the move to a main folder and then had to re-zip it for wordpress to upload. thanks everyone!

    Thank you soooooo much @razmzk I was having the same poblem. When I unpacked the download file, there was very clear documentation as to how to install it and it worked flawlessly! I’m used to working with Joomla where the archived file IS the template… Thanks again. #Lifesaver!!!

    Ok back to my fumbling…

    I have the same problem. But then i opened the style.css File
    I was Surprised as it Was Blank.
    SO finally i came to know that the theme has some color Scheme like Black, WHite. And if you will upload that with FTP, the theme will not select any colour scheme and hence it will be broken.
    SO the Solution is:
    Upload the Theme with FTP
    Now simply go to that particular theme setting and select/Change the colour scheme.
    And now you will see its working.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘The theme is missing the style.css stylesheet’ is closed to new replies.