Support » Plugin: Super Progressive Web Apps » The SuperPWA App opens a browser

  • Hello everyone!

    When I installed the SuperPWA plugin 6 months ago it was working fine. People were saving the website to their screen and it was working with the splash screen and everything.

    Recently I tried to save the website to the phone of a friend of mine and I was surprised to see that after the icon appears on the home screen, it simply opens our website in a browser – no splash screen, no start page, no offline page, no nothing. It is even booting the website through the unsecured http:// protocol, which opens the website with absolutely no styling.

    I tried on about five different smartphones – Android and iOS. I also noticed that the scroll box has stopped appearing as well.

    Otherwise, the plugin is activated. Also, whoever has added the website to his home screen six months ago is not affected by this, including me. This is why I haven’t noticed until I tried to put it on someone else’s phone.

    We will really appreciate your help in solving this!

    Thank you!

    Damyan
    https://haha.bg

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m new to this plugin, but in the changelog, they added a setting as to how the app should be opened.

    Maybe the previous option is no longer the default and you are now seeing the default behaviour.

    You can set it to open like an app, in a browser or in a browser with minimal controls.

    I’m seeing that phones heavily cache the app though, so changing things like icons doesn’t show unless you clear the application cache in chrome.
    Unfortunately, I find that that deletes all of my history rather than just for that website.

    But… check the settings of the plugin and wait.

    Thread Starter Damyan90

    (@damyan90)

    Dear @robwent

    You are the only indication of “support” for the past 3 weeks. Thank you!

    That’s the thing. The plugin settings stays with Display: Standalone, which I believe is the setting you refer to. Let me know if you have something else in mind.

    Cheers!

    Click on the link to view the manifest file in the plugin settings.

    It should say : “display”:”standalone”

    If that’s the case then it might be a caching issue.

    Try removing the app and then add it again with a different browser (I think brosers cache manifest files for a long time. At least that’s my experience with chrome not picking up changes with app icons).

    It also looks like the manifest file does not use versioning, so if you have anything like cloudflare or a cdn in use then you may need to purge the cache for that file for any changes to show.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘The SuperPWA App opens a browser’ is closed to new replies.