Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » the styles in editor-style.css are no longer being rendered in the editor

Viewing 14 replies - 1 through 14 (of 14 total)
  • WebSkilz


    I am having the same problem. I am no longer able to load the styles from the editor-style.css file into TinyMCE. Please advise.

    Plugin Author Andrew Ozz


    Assuming you’ve checked the new checkbox: “Load the CSS classes used in editor-style.css and replace the Formats button and sub-menu.”, clean the browser cache and try again. There is a new “importcss” TinyMCE plugin now, should work better.

    Thread Starter iframe


    Andrew, thanks for looking into the matter.

    However, before I submitted this issue one week ago, I have played with all possible combinations of checkboxes being checked on/off just to load styles from the editor-style.css

    I just followed your advice. The issue is still there, styles won’t load.



    Plugin Author Andrew Ozz


    Do you see the same styles applied in the editor? To check: add an element where a style should be applied, right-click it and select “Inspect element”. Then look at what styles are applied and where they come from (which file). This may give some clues about what’s going on 🙂

    I’m having the same problem… the editor-style.css is completely missing. This was the most valuable tool for us. Is there a solution yet?

    I have tried these steps and am still unable to get my editor-style.css working with the new tinymce update. Andrew, is there anything else that we can try to get this working again with your plugin?

    Same for me.

    Everyone is talking about the styles drop down but I guess this is now called the Format list in the latest version of WordPress. (Or is there some way to make ‘styles’ reappear?)

    I’m also having this problem. And, yes, I’ve had “Load the CSS classes used in editor-style.css and replace the Formats button and sub-menu.” checked. I’m using version 4.0.2.

    Plugin Author Andrew Ozz


    Few steps to troubleshoot this:
    1. Make sure the editor-style.css file actually exists in your theme and the styles you want to import in the editor menu are not imported in the css with @import....
    2. Delete the browser cache and reload the Edit Post screen several times. All browsers tend to reuse css in iframes.
    3. Add something to test if editor-style.css is loaded in the editor. Something like p { color: red !important; } should work (all text in the editor should be red).

    Hi Andrew. Thanks for the troubleshooting steps. I deleted the contents of my editor-style.css file and replaced the code with p { color: red !important; } as you suggested.

    It shows the font as red when I am typing in the editor, so it appears to be loading your suggested code into the editor. However, the “Formats” drop down button is still blank (just as it was prior to testing your suggested red CSS style).

    I cleared out the cache and reloaded everything and the same problem is there. Please advise what needs to be done to make the “Formats” drop down button show the different styles to select from.

    FYI, the following two boxes are checked off in your plugin:
    – Import editor-style.css.
    – Load the CSS classes used in editor-style.css and replace the Formats button and sub-menu.

    It used to show all of my css styles in the styles drop down button prior to this tinymce upgrade.

    Lastly, please clarify what you mean about making sure that the styles are not imported in the css with @import… I wasn’t quite sure what you meant by that statement.

    Thanks again for your help!

    Well, it’s sorted for me now but I’m still a bit puzzled about why it didn’t work previosly.

    I went to the codex page ( and used the simplest possible arrangement with these extra lines in my child theme’s function file:

    function cm_styles(){
    add_action( ‘init’, ‘cm_styles’);

    Put my styles in editor_style.css in my child theme and it all worked. Previously I had been using a named css file and it didn’t work.

    Hi, Andrew.

    I tried your troubleshooting steps. Still seeing the issue AND the !important line DID NOT load. It really seems like editor-style.css is not being loaded.


    Also, I tried stevekimpton’s tip — and this DID work. Then my red H3 style loaded, along with all my other editor-style.css styles. I actually just added this:

    function my_theme_add_editor_styles() {
    add_editor_style( ‘editor-style.css’ );
    add_action( ‘init’, ‘my_theme_add_editor_styles’ );

    io mi sono scocciato di provare e riprovare. Disinstallo e reinstallo la vecchia versione. Per me accedere agli stili css dal visual, era una comodità straordinaria e non ci voglio rinunciare.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘the styles in editor-style.css are no longer being rendered in the editor’ is closed to new replies.