Support » Plugins and Hacks » XML Sitemap & Google News feeds » [Resolved] the sitemap get 404 error on google webmaster.

[Resolved] the sitemap get 404 error on google webmaster.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author RavanH


    Are there any rules in your Apache VirtualHost file or .htaccess related to xml file requests? If so, remove them to let WordPress handle the requests.

    The sitemap index http://www.tvqc.com/sitemap.xml responds with a 200 OK but I notice it takes a really long time. About 40 seconds… this is not normal, certainly not for a server with Varnish running. Then subsequent sitemaps like http://www.tvqc.com/sitemap-posttype-post.2014.xml indeed give a 404 Not Found header even though the content is there. Strange.

    Even stranger is the difference between http://www.tvqc.com/sitemap-home.xml (with a 404 and content from another sitemap plugin!) and http://www.tvqc.com/?feed=sitemap-home (a 200 status and correct content) which should be the exact same sitemap.

    Are there any static .xml files in the site root? If so, please delete them all. Then go to Settings > Permalinks and re-save the settings. Also make Varnish purge its cache.

    Next, you might try disabling all other plugins to see if one of them is responsible for the 404 header. Use a tool like http://web-sniffer.net/ to test the sitemaps.

    If all that does not help, the most likely source is your server setup…

    ok ive flush all my plugin which could potantialy interfer with stemap plugin ive refresh my permalink and now my sitemap look like «XML Sitemap source as read by search engines» split by mouth, even if i choose the by years option.

    when im trying to post one of the sitemap i get this error

    View post on imgur.com

    Thank you for the fast reply 🙂

    If it may elp thhe google news sitemap is working perfectly

    Plugin Author RavanH


    sitemap-tax_post.xml is not a sitemap made by my plugin but by another one. You cannot run two sitemap generators at the same time without conflicts.

    Please choose one of them and then follow the instructions carefully to avoid confusion.

    sorry here is the good link/iamge


    View post on imgur.com

    Plugin Author RavanH


    Looking at the source code of I notice at the bottom these lines that should not be there:

    <p id="authorsure-last-updated" class="updated" itemscope="itemscope" itemtype="http://schema.org/WebPage" itemid="http://www.tvqc.com/2014/01/shingeki-bahamut-une-adaptation-anime-pour-le-jeu-de-carte-en-ligne/">Dernière mise à jour par : <span style="float:none" class="author vcard"><span class="fn"><a rel="author" href="http://www.tvqc.com/author/jeff/" class="authorsure-author-link">Jean-François Cloutier</a></span></span> le <time itemprop="dateModified" datetime="2014-04-20T14:15:31+00:00">20 April 2014</time>.</p>

    This is not part of my plugin and I have no idea how they got there. Are you using some plugin that adds an author vcard to feeds?

    Authorsure is a plugin for google autorship ill give it a look

    Plugin Author RavanH


    If it has an option that allows disabling these additions to feeds, please use that. Otherwise, simply disabling it should help too 🙂

    Please let me know the result. Wwhen disabling the plugin is the only way to solve the issue, and you would like to keep using Authorsure then you might want to consider another XML Sitemap plugin.

    In any case, thanks for the report 🙂

    Plugin Author RavanH


    I just got a message about Polylang 1.5 beta fixing some bugs that where introduced with the 1.4 version. It might just include your issue… Read more and download from http://polylang.wordpress.com/2014/04/21/polylang-1-5-beta/

    ok i’ve disable autorsure and now it work
    in fact autorsure seem to bug all others sitemaps plugin…

    View post on imgur.com

    also if it may helo you my site is in french so i must add Native RSS plugin to get it to work

    Native RSS Plugin

    Plugin Author RavanH


    If your WP installation is cofigured correctly (French version from http://fr.wordpress.org/) then there should be no need for a plugin like native rss. The language tags in all feeds should be “fr-FR” by default. If that is not the case on your site, then there is something wrong…

    I notice you are using another plugin for your Google News Sitemap. Why? Is the Google News function in my plugin not working for you? Or is it a static file sitemap-news.xml in your site root that you have not deleted yet?

    your news sitemap is ok aswell

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] the sitemap get 404 error on google webmaster.’ is closed to new replies.
Skip to toolbar