• Resolved mogorash

    (@mogorash)


    Привет!

    Начиная с версии 5.2 WordPress может определять возникающие ошибки с плагинами или темой на сайте и присылать вам подобные сообщения автоматически.

    В этот раз WordPress нашел ошибку с одним из плагинов – WP Testimonials.

    Сначала зайдите на ваш сайт (http://3.cakeart.by/) и проверьте все видимые проблемы. Далее, зайдите на страницу, на которой возникла ошибка (http://3.cakeart.by/wp-admin/admin.php?page=testimonial-widgets/tabs/setup-guide.php) и проверьте видимые проблемы на ней.

    Пожалуйста, обратитесь в техническую поддержку хостинга для дальнейшей диагностики этой проблемы.

    Если ваш сайт сломан и вы не сможете нормально войти в консоль, теперь можно использовать специальный “режим восстановления”, который позволит безопасно войти в консоль для дальнейших действий.

    http://3.cakeart.by/tsekhach?action=enter_recovery_mode{removed by moderator}

    В целях безопасности действие этой ссылки истекает через 1 день. Но не беспокойтесь, если ошибка возникнет снова по истечении этого времени, то вам будет выслана новая ссылка.

    Для решения проблемы вам потребуется следующая информация:

    Версия WordPress 6.0.3
    Текущая тема: Woodmart (версия 7.0.2)
    Проблемный плагин: WP Testimonials (версия 1.3.3)
    Версия PHP 8.1.11

    Подробности ошибки
    ===================================
    Ошибка с типом E_ERROR возникла на строке 370 файла /home/cakeartb/3/wp-content/plugins/testimonial-widgets/testimonials-plugin.class.php. Сообщение об ошибке: Uncaught ValueError: Unknown format specifier “S” in /home/cakeartb/3/wp-content/plugins/testimonial-widgets/testimonials-plugin.class.php:370
    Stack trace:
    #0 /home/cakeartb/3/wp-content/plugins/testimonial-widgets/testimonials-plugin.class.php(370): vsprintf()
    #1 /home/cakeartb/3/wp-content/plugins/testimonial-widgets/tabs/setup-guide.php(37): TrustindexTestimonialsPlugin::___()
    #2 /home/cakeartb/3/wp-admin/admin.php(293): include(‘/home/cakeartb/…’)
    #3 {main}
    thrown

    • This topic was modified 1 year, 8 months ago by Yui.
    • This topic was modified 1 year, 8 months ago by Yui. Reason: unnecessary possibly sensitive data redacted
    • This topic was modified 1 year, 8 months ago by mogorash.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter mogorash

    (@mogorash)

    The error disappears when you include a version of php 7.4 or below

    • This reply was modified 1 year, 8 months ago by mogorash.
    Plugin Support 96dervalics

    (@96dervalics)

    Hello @mogorash!

    We are working on the solution.
    Could you confirm that if you change the langauge to english the error disappears?

    Trustindex

    Plugin Support 96dervalics

    (@96dervalics)

    Hello @mogorash!

    Updating your plugin to the latest version will solve the problem!

    Feel free to write us, if you need any assistance,
    Trustindex

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘The site encountered a critical error’ is closed to new replies.