Support » Plugin: AMP » The setup wizard has experienced an error

  • Resolved metodija

    (@metodija)


    I am getting the following error on the screen when on the wizards page:

    The setup wizard has experienced an error.
    The response is not a valid JSON response. Return to AMP settings.

    In the console, i am getting a number of errors:
    1. /amp/v1/options?_locale=user – 404
    2. Uncaught SyntaxError: missing } after property list admin.php:262:3488 note: { opened at line 262, column 3266

    Do you know why this is the case.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Renee Johnson

    (@reneesoffice)

    @metodija thanks for your topic!

    1) Could you provide a URL to your site?

    2) To rule out other plugins/ your theme, could you use the Health Check & Troubleshooting plugin and enable its troubleshooting mode. This mode disables active plugins and switches to a default theme safely since it only affects the experience of the logged-in user.

    – Please enable the AMP plugin and let me know if the issue is present.
    – Enabling plugins and your theme one by one in this mode may help pinpoint if something else is involved.
    – Note you can disable troubleshooting mode from the plugins page.

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    Thanks for your instant reply.
    The health plugin didn’t work for me, i did press Enable troubleshooting, however it didn’t ask me to disable plugins.
    However i did disable all the plugins previously, and the issue still persisted.
    Only when i change themes that the AMP plugin started working.
    So it has something to do with the theme, I use SAGE framework, so i think it has something to do with the path.
    Can i supply you with the URL privately?

    Thanks

    Renee Johnson

    (@reneesoffice)

    @metodija thanks so much for your reply. Yes, you can send us the URL and your Site Health information (which will be additionally helpful) through this form.

    @metodija thanks for the Site Health information. While I confer with the team about your case, I notice that the value for your site URL references a completely different URL altogether in a subfolder.

    We also see that visiting this URL directly leads to an access denied error, possibly generated from the server. Is this part of your theme setup?

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    thanks for your email.
    Yes that is part of the setup, we have the admin and frond end part running on different url’s. The front url is internal only so you won’t be able to access it.
    However you can still access the front end using the admin url. I can also change it in wp-options in the mean time for testing so both url’s are the same as admin.
    Whatever suits you.

    Let me know.

    Thanks

    @metodija thanks for your reply! yes, that would be great if you could try updating so that both urls are the same as the admin. Let us know if that helps.

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    All done now, they both match.
    Although ideally i would need the plugin to work on different urls.
    I have also sent you a user name and pass on the form above so you go to admin
    Please let me know if you can login.

    Thanks

    @metodija thanks for your reply!

    We are not allowed to access your site (so it may be best to delete those credentials). However, could you let us know if the wizard is running properly or are you still encountering the error?

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    Thanks for your email.
    You should have access the url I provided you with is open. Please check the form again, I have resent the url. Please use the login details I provided you with yesterday.
    The wizard doesn’t work either.
    If you click on Amp on the left hand side menu, there is a spinning icon, check the console errors.

    Please let me know how you go, it’s quite urgent now.

    Thanks

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    Just further to this the error I get is 404 not found in the console:
    {Domain}/amp/v1/options?_locale=user

    When I type this url in the browser and change it as below:
    {Domain}/wp-json/amp/v1/options?_locale=user
    I don’t get 404 anymore but the below:
    Amp_rest_cannot_manage_options, sorry you are not allowed to manage options for the AMP plugin for WordPress.

    Thanks

    @metodija thanks for the reply.

    Sorry, it is not accordance with forum guidelines and our practice to access/ login into your site directly.

    However, could you let us know the following:

    1) Is your REST API working properly for other admin screens? For example, are you able to edit posts in Gutenberg?

    2) Could you check the source code (right click, then select View source) on the AMP settings page and search for lines of code similar to this:

    <script id='wp-api-fetch-js-after'>
    wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://example.com/wp-json/" ) );
    wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "d822cdb8fe" );
    

    Which is the URL for “example.com”?

    If you can also provide this information when you revert the site back to the different URLs that would be helpful.

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    When changing the different url it still outputs the error.
    Only when i change themes that it starts to work.
    The difference between the 2 themes is that on the culprit one it adds double quotes insted of single:
    <script id=”wp-api-fetch-js-after”>
    This is the line: “Twenty Fifteen”s simple,”

    The error happens on the following place as well:
    <script id=”common-js-translations”> – Uncaught SyntaxError: missing : after property id

    Thanks

    @metodija thanks for getting back and for this additional info. We’re trying to map the current functionality of the plugin to your theme’s setup to see where the issue resides.

    I see you’ve restored the site back to the initial setup.

    – Are you able to use and access the Gutenberg editor currently (is the REST API working properly) on your site?

    – Could you send us screenshots of what you see in the source code for those two script tags in full (as in the code snippet above)?

    You can provide links to screenshots using a service like Imgur or Jumpshare.

    We’ll need to know which URL is present in the code (the site url or the home url). Feel free to share these links to screenshots privately through the form.

    Thread Starter metodija

    (@metodija)

    Hi Renee,
    Thanks for your email.
    On my current theme, i cannot access Gutenberg, i get a blank screen.
    Changing the urls make no difference.
    Once i change themes to twenty twenty that i can gutenberg. However i can only save when the urls are both the same and point to the open url.

    The theme i use is causing this, i use the sage framework.
    I have prepared and sent the additional info the form above.

    Please let me know what the issue could be. I really need this sorted.

    Thanks

    @metodija thanks for the information you’ve provided. I’m checking with the team regarding the expectation in your case. Thanks for your patience.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.