WordPress.org

Forums

Yoast SEO
[resolved] The SEO Metabox doesn't show up with my Custom Post Types (4 posts)

  1. jayllellis
    Member
    Posted 3 years ago #

    Hey, I don't know why but for some reason the SEO metabox doesn't show up with my custom post types. I even added this line to my register post type function: 'public' => true and it still doesn't show up.

    Anyone have a solution? Please.

    http://wordpress.org/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 3 years ago #

    Disable all other plugins and revert to the twenty-twelve theme - does the SEO box show up then for the custom post type ?
    If so, the problem is not with WP SEO.

    If it doesn't show up, please provide more info it does work for other people, so there is no way to start analysing this based on the limited info you've given now.

  3. jayllellis
    Member
    Posted 3 years ago #

    Thanks for your response. I tried this and it doesn't work. A bit more info: it's a custom post-type with a few custom fields that I'm trying to edit.

  4. jayllellis
    Member
    Posted 3 years ago #

    Ok, I just figured out that with Yoast you can use a custom field value as the meta description, etc. Therefore I just added a custom field for title and meta description to my custom post type. Thanks for you help though :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic