Support » Plugin: WP Google Search » The search box is showing / Not working

Viewing 14 replies - 1 through 14 (of 14 total)
  • +1 The box used to work, but it is no longer displayed in Chrome (IE and Edge work just fine). This probably has to do with Google dropping iFrame display, but just changing the result page layout doesn’t bring back the widget.
    I also checked if my search engine ID changed, but that is not the case.

    Plugin Author WebshopLogic

    (@webshoplogic)

    Hi,

    It can be a site specific problem, because on our test sites the search box widget is shown without any problem.

    I can see that the search box is displayed now on cutesunita21’s site.

    @roy, can you send us a url where the problem is seen?

    Thanks,
    Peter

    Peter thank you for your reply. It’s a Chrome version thing it seems. Yesterday I was working on the website at home when I noticed the search widget didn’t appear, so I thought I wrecked something. When I noticed that it did work in IE and Edge, my guess was that it was due to Chrome. I searched a bit, found threads implying that Google changed the custom search and tried the suggested options.

    Now I’m at work and the widget does work in Chrome. When I wanted to look up which version is running here, Chrome started to update. When it was done, the widget didn’t load immediately, but after a while I did. So your plugin works in Versie 60.0.3112.101 (OfficiĆ«le build) (32-bits) and the version I had before here (at work). I’ll look up what version is running at home.

    For your reference, this is the concerning website.

    At home we have 60.0.3112.90

    Plugin Author WebshopLogic

    (@webshoplogic)

    Thank you for the detailed information.

    My actual Chrome version is 60.0.3112.90, and I cannot realize this problem, the search box is displayed on your site properly using this Chrome version. Thus this may not in connection with the Chrome version.

    However both Chrome and Google Custom Search are belong to Google (this plugin just insert Google code into a WP site, but the search code is made by Google), thus it seems to be a problem at Google side.

    I suggest you to report this problem to Google, maybe they know the reason of this.

    If we can change anything in the plugin let us know.

    It has to be some odd combination of things. A fact is that here at work I’m behind a proxy, usually a reason for such vague malfunctions, but ironically it does work here, but not at home where I (of course) do not use a proxy. It’s not my connection, otherwise it wouldn’t have worked in Microsoft’s products. A combination of plugins is unlikely, otherwise it wouldn’t have worked anywhere. Same for theme incompatibilities.

    I’ll do some more digging. I can try to update Chrome at home (I actually expected it do to that automatically), see what Firefox comes up with and continue from there.

    Can I ask HOW your plugin displays the Google search form in a widget? That’s not an iframe I suppose? The way it loads after the rest of the page, my guess is that this form is loaded directly from the Google server and is not displayed using WP (and only the search itself is handled by Google).

    This is annoying. Chrome at home didn’t show the widget and when I updated to
    Versie 60.0.3112.101 (Officiƫle build) (32-bits)
    the latest version, there is still no widget.

    IE, Edge and Firefox are just fine.

    Why oh why doesn’t Chrome work properly at home, while it does at work?

    Arg, deleting and replacing the widget makes no different. De- and reactivating the plugin doesn’t either (oddly enough, the widget is still there under appearance->widgets when I deactivate the plugin). It doesn’t appear to be browser cache, as when I change the title, this is updated immediately. Besides, I always work with in private tabs…

    Plugin Author WebshopLogic

    (@webshoplogic)

    Do you have any JavaScript error message on the browser console?
    In your browser can you see the search box on our site? (It is http://webshoplogic.com, and the search box have to be shown after clicking on search button in the menu.)

    The search box is not in iframe, it is a html form in some div tags generated by Google.

    No error message, just an empty widget.

    The search icon that ‘produces’ a search bar is the standard search option of the theme and it uses the standard search function of WP, hence: only the current site. I use your plugin to give the possibility to search the entire website.

    What happens in Chrome at my PC is that the title of the widget is visible (“search website”), but the Google custom search is not. It’s just an empty widget with only a title. The rest of the sidebar even moves up to fill the gap, so it’s not like there’s a black space where the Google search needs to be. Other said otherwise: the site remains as it was before the Google search bar is loaded. In another browser you can also see that the search bar loads a little later than the rest of the page.

    Of course I’m not at home right now (start of the working day), so I can’t try to see if I see the searchbar on your site. Good suggestion though. I hope I’ll think to check when I’m back home.

    Roy

    (@gangleri)

    Sorry, it took a long time before I reminded to test this and having access to my personal PC at the same time :-/

    Result: when clicking the search icon on your website, a bar appears, but it remains empty. I have no space to click to type a search term.

    Just checked to see if the source code of my website is the same in Chrome as in IE and it is. I think this means that Chrome doesn’t block anything, but it doesn’t em show everything either.

    Roy

    (@gangleri)

    I just noticed that the search on WP.org doesn’t work either. I can type a search term here, but then nothing happens. It has to be the Chrome install. I’ll reinstall and see what happens.

    Roy

    (@gangleri)

    Sigh, that should have been option one… Reinstallation solved the.

    Excuses and thank you for your time.

    Plugin Author WebshopLogic

    (@webshoplogic)

    We are happy that the problem is solved, thanks for the feedback.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘The search box is showing / Not working’ is closed to new replies.