Support » Plugin: WP Mail SMTP by WPForms » The result was: bool(false)

  • baumlol

    (@baumlol)


    Hello,

    I’m using identical settings on localhost and online. On localhost the plug-in is working like a charm – online I’m always receiving bool(false) when I want to send a test mail.

    This is my log:

    object(PHPMailer)#4607 (69) {
      ["Version"]=>
      string(5) "5.2.7"
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(22) "SMTP connect() failed."
      ["From"]=>
      string(22) "***@***.de"
      ["FromName"]=>
      string(11) "***"
      ["Sender"]=>
      string(0) ""
      ["ReturnPath"]=>
      string(0) ""
      ["Subject"]=>
      string(47) "WP Mail SMTP: Test mail to ***@***.de"
      ["Body"]=>
      string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
      ["AltBody"]=>
      string(0) ""
      ["Ical"]=>
      string(0) ""
      ["MIMEBody":protected]=>
      string(69) "This is a test email generated by the WP Mail SMTP WordPress plugin.
    "
      ["MIMEHeader":protected]=>
      string(436) "Date: Mon, 18 May 2015 11:48:53 +0000
    Return-Path:
    To: ***@***.de
    From: ***
    Subject: WP Mail SMTP: Test mail to ***@***.de
    Message-ID:
    X-Priority: 3
    X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
    MIME-Version: 1.0
    Content-Type: text/plain; charset=UTF-8
    Content-Transfer-Encoding: 8bit
    
    "
      ["mailHeader":protected]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["UseSendmailOptions"]=>
      bool(true)
      ["PluginDir"]=>
      string(0) ""
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["MessageDate"]=>
      string(0) ""
      ["Host"]=>
      string(12) "send.one.com"
      ["Port"]=>
      string(3) "465"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(3) "ssl"
      ["SMTPAuth"]=>
      bool(true)
      ["Username"]=>
      string(22) "***@***.de"
      ["Password"]=>
      string(16) "***"
      ["AuthType"]=>
      string(0) ""
      ["Realm"]=>
      string(0) ""
      ["Workstation"]=>
      string(0) ""
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      bool(true)
      ["Debugoutput"]=>
      string(4) "echo"
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["SingleToArray"]=>
      array(0) {
      }
      ["do_verp"]=>
      bool(false)
      ["AllowEmpty"]=>
      bool(false)
      ["LE"]=>
      string(1) "
    "
      ["DKIM_selector"]=>
      string(0) ""
      ["DKIM_identity"]=>
      string(0) ""
      ["DKIM_passphrase"]=>
      string(0) ""
      ["DKIM_domain"]=>
      string(0) ""
      ["DKIM_private"]=>
      string(0) ""
      ["action_function"]=>
      string(0) ""
      ["XMailer"]=>
      string(0) ""
      ["smtp":protected]=>
      object(SMTP)#4671 (12) {
        ["Version"]=>
        string(5) "5.2.7"
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        bool(true)
        ["Debugoutput"]=>
        string(4) "echo"
        ["do_verp"]=>
        bool(false)
        ["Timeout"]=>
        int(10)
        ["Timelimit"]=>
        int(30)
        ["smtp_conn":protected]=>
        bool(false)
        ["error":protected]=>
        NULL
        ["helo_rply":protected]=>
        NULL
        ["last_reply":protected]=>
        string(0) ""
      }
      ["to":protected]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(20) "***@***.de"
          [1]=>
          string(0) ""
        }
      }
      ["cc":protected]=>
      array(0) {
      }
      ["bcc":protected]=>
      array(0) {
      }
      ["ReplyTo":protected]=>
      array(0) {
      }
      ["all_recipients":protected]=>
      array(1) {
        ["***@***.de"]=>
        bool(true)
      }
      ["attachment":protected]=>
      array(0) {
      }
      ["CustomHeader":protected]=>
      array(0) {
      }
      ["lastMessageID":protected]=>
      string(49) ""
      ["message_type":protected]=>
      string(5) "plain"
      ["boundary":protected]=>
      array(3) {
        [1]=>
        string(35) "b1_c05fd8a13dcab007169edc008b9cf8cf"
        [2]=>
        string(35) "b2_c05fd8a13dcab007169edc008b9cf8cf"
        [3]=>
        string(35) "b3_c05fd8a13dcab007169edc008b9cf8cf"
      }
      ["language":protected]=>
      array(18) {
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["data_not_accepted"]=>
        string(30) "SMTP Error: data not accepted."
        ["empty_message"]=>
        string(18) "Message body empty"
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["execute"]=>
        string(19) "Could not execute: "
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["invalid_address"]=>
        string(15) "Invalid address"
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["provide_address"]=>
        string(54) "You must provide at least one recipient email address."
        ["recipients_failed"]=>
        string(45) "SMTP Error: The following recipients failed: "
        ["signing"]=>
        string(15) "Signing Error: "
        ["smtp_connect_failed"]=>
        string(22) "SMTP connect() failed."
        ["smtp_error"]=>
        string(19) "SMTP server error: "
        ["variable_set"]=>
        string(30) "Cannot set or reset variable: "
      }
      ["error_count":protected]=>
      int(2)
      ["sign_cert_file":protected]=>
      string(0) ""
      ["sign_key_file":protected]=>
      string(0) ""
      ["sign_key_pass":protected]=>
      string(0) ""
      ["exceptions":protected]=>
      bool(true)
    }
    The SMTP debugging output is shown below:
    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

    Can you help me with that? Thanks in advance! Good plug-in!

    Best Regards

    https://wordpress.org/plugins/wp-mail-smtp/

Viewing 1 replies (of 1 total)
  • Jason Hendriks

    (@jasonhendriks)

    You tried send.one.com:465 with SSL and got “A connection timed out”. This means the host you are on is probably blocking port 465. Why don’t you try send.one.com:587 with TLS or send.one.com:2525 with TLS as this page suggests?

Viewing 1 replies (of 1 total)
  • The topic ‘The result was: bool(false)’ is closed to new replies.