Support » Fixing WordPress » The requested URL /us-preppers.com/register/ was not found on this server

  • I’m having a problem with pages not being found pretty much immediately after they have been created.
    First things first. I am running Apache 2.4, MySQL 5.0 PHP5.5.36 WordPress 4.6.1 on a WIndows 7 machine.

    I have been trying to install Buddypress and a couple of other plugins such as s2Menber and BBpress. In the process of working on this my site seems to have lost all of its pages. I have a number of pages I have created. many were created before any plugins were installed. I am now finding that none of my pages are reachable. All pages except my “Front page” i.e. “Homepage” whether from the live site i.e. http://localhost/my-site.com or from a link on the frontpage or a link from within the admin area of the site in other words “Dashboard > Pages > mypage > Edit Page > Permalink > or even ‘Preview Changes'” nothing will connect to any page except the ‘Front’ or ‘Home’ page.
    Everything else gives me an error page with the message…
    The requested URL /us-preppers.com/register/ was not found on this server

Viewing 15 replies - 1 through 15 (of 15 total)
  • Try to refresh Write-Urls-Rules :

    Dashboard -> settings -> Permalinks -> click Save Changes, and see if its working.

    Update to “lost pages” issue.

    I reset Permalinks “Dashboard > Settings > Permalinks” to “Plane” which apparently fixed all the problems with finding all the pages.

    However when I tied changing that setting back to “Post name” WordPress again lost all of my pages. giving me the error…

    The requested URL /us-preppers.com/store/ was not found on this server.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Team Volunteer

    That sounds like an issue with .htacess. Did you make any changes to your httpd configuration?

    SIdati,

    Thank you for your reply but I don’t know what you are referring to.
    I don’t know what the “Write-Uris-rules” is and I don’t see anything like that on the Permalinks page.

    You know that almost sounds familiar, but if I did it’s been some time now. As i’m thinking about it now I’m thinking the only such change I may have made would have been related to a CURL issues and WordPress not being able to download updates.

    First things first. I am running Apache 2.4, MySQL 5.0 PHP5.5.36 WordPress 4.6.1 on a WIndows 7 machine…
    …Permalinks” to “Plane” which apparently fixed all the problems with finding all the pages.
    However when I tied changing that setting back to “Post name” WordPress again lost all of my pages. giving me the error…

    The 404 errors on anything other than the default permalink structure can be an indication that mod_rewrite has not been enabled for Apache, or that the “Allowoverride All” directive has not been configured for your host container.

    If you’re running on Wampserver:

    Try click on the green WampServer icon in the system tray or task bar, select Apache > Apache modules > then scroll down the module list until you come to “rewrite_module”, and place a check mark next to it. The server should restart itself.

    If you’ve installed the server environment manually, or are using some other pre-packaged installation, you probably need to enable mod_rewrite for Apache for permalinks to work.

    I’ve uncommented this line…

    “LoadModule rewrite_module modules/mod_rewrite.so”

    in httpd.conf then restarted Apache. This didn’t help . Still not connecting to pages.

    On a windows machine I think it might be mod_rewrite.dll, but you may want to research that a bit to be sure.

    After that, be sure to restart Apache.

    If that fails, research the “Allowoverride All” directive that allows the use of rules in .htaccess files. You can find a global configuration for that directive in httpd.conf, as well as references to using it virtual host containers on a per site basis in the Apache documentation.

    Note: all components are installed separately i.e. Apache, MySQL, & PHP. No bundled package.
    I’m not finding a lot of helpful info relating to “Allowoverride All”. What I am finding is kind of difficult to follow. So far not sure how best to proceed.

    Windows will probably read the mod_rewrite.so with no problem, but loading the .dll version was just a suggestion if it’s actually there in the file.

    I’m not finding a lot of helpful info relating to “Allowoverride All”.

    At this point, I’ll be up front with you and tell you any changes you make you do at your own risk if you’re not familiar with the server environment. That said..

    In httpd.conf you should find a section that – looks like/similar to – this:

    
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride None
    
    

    Try changing “None” to All, then save the changes and restart apache and test the results.

    [edit] ..just to clarify: change AllowOverride None to AllowOverride All

    • This reply was modified 2 years, 3 months ago by  Clayton James.
    • This reply was modified 2 years, 3 months ago by  Clayton James.
    • This reply was modified 2 years, 3 months ago by  Clayton James.

    OK that didn’t work. i Found “Allowoverride All”. in the httpd.conf file and changed “none” to “all”

    To be clear I found these lines…

    <Directory “c:/Apache24/cgi-bin”>
    AllowOverride None
    Options None
    Require all granted
    </Directory>

    And I changed “None” to “all’
    I then restarted Apache but this still did not fix anything.

    Try to deactivate all plugins and delete your .htaccess then go to :
    Dashboard -> settings -> Permalinks -> click Save Changes, and see if its working.

    if so try to activate plugins one by one and every time you activated a plugin see if pages still working so you can locate the “bad plugin.

    That’s the wrong one, you went too far down in the file. Change that one back.

    Do a search on the term .htaccess – there should only be two or three occurrences of the word in the file – until you find the line that says:

    # AllowOverride controls what directives may be placed in .htaccess files.

    That’s the one you want to change, below that block.

    WOO HOO !!! that looks like it was the culprit

    Thank you for the help and the patience. And also thanks to everyone else who offered their help. It is very much appreciated.

    You’re the one who actually did all the work, but you’re welcome! Glad it did the trick. 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘The requested URL /us-preppers.com/register/ was not found on this server’ is closed to new replies.