WordPress.org

Ready to get started?Download WordPress

Forums

The requested URL /index.php was not found on this server (7 posts)

  1. bolamuyis
    Member
    Posted 2 years ago #

    I need to make some changes to the WP site that was not built by me. I copied all the files of the server and also did a sql export to my local computer. The landing page loads up just fine save for a few images. However the links to other pages bring up the following error:

    Not Found
    The requested URL /index.php was not found on this server.
    Apache/2.2.21 (Unix) DAV/2 PHP/5.3.10 with Suhosin-Patch Server at localhost Port 80

    Can someone help, please...

  2. ClaytonJames
    Member
    Posted 2 years ago #

    also did a sql export to my local computer.

    Did you do a search and replace on the database to change all of the live domain name references to your localhost address ( localhost, internal ip - whatever you used to install wordpress on your local machine) before importing to the local installation?

  3. bolamuyis
    Member
    Posted 2 years ago #

    Yes, I did change all live domain references to the localhost address before the import.

  4. ClaytonJames
    Member
    Posted 2 years ago #

    Could it be a permalink issue? Example: Live server setup -vs- local development server setup - is mod_rewrite enabled and working on your local machine, and is "AllowOverride All" configured for the local site host container (or globally configured in httpd.conf) to make sure your server will obey any rewrite rules that might be in the .htaccess file you transferred from the live server?

  5. bolamuyis
    Member
    Posted 2 years ago #

    I think you might be right. Would you kindly tell me the steps I should take to address these this. I don't know exactly where to start or what to do. Thanks in advance.

  6. ClaytonJames
    Member
    Posted 2 years ago #

    If it's a newer debian OS, it might be as easy as opening a terminal and running:

    sudo -i

    a2enmod rewrite

    Then you need to edit the default site.

    Open this with your favorite editor:

    /etc/apache2/sites-available/000-default

    Find this..

    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all

    and change it to...

    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order allow,deny
    allow from all

    and restart the server..

    service apache2 restart

    If you use a different OS and you can edit httpd.conf directly, open httpd.conf and find this:

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit

    AllowOverride None

    and change it to...

    AllowOverride All

    ...and restart the server. I think that should usually get mod_rewrite working in either case.

  7. thi audio
    Member
    Posted 2 years ago #

    Hello, i am new in web maintaining.. i am trying to login into my admin/dashboard (with all my menu, pligin, pages, post library) page, but giving me an error "Not Found The requested URL /index.php was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
    The godaddy is host (and i have back up .rar file).. i need help and my website now looks weird too.. i searche in forum, but i need detailed help (step By step) if is there hope.. PLEASE HELP

Topic Closed

This topic has been closed to new replies.

About this Topic