The requested URL /activity/ was not found on this server. (3 posts)

  1. fernandocassola
    Posted 3 years ago #

    Hello i've installed a site with wordpress (3.4.2) and then install the BudyPress 2.1.2
    But I have a serious problem. The pages of BuddyPress (activity, forums, groups, members), appearing not work always the error: The requested URL / activity / was not found on this server.

    I've been arround of solving this problem for over a week, who can help me, thank a lot ..

    Many thanks

    Best regards


  2. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    @fernandocassola After you activate BuddyPress plugin, you need to go through the Installation Wizard http://codex.buddypress.org/getting-started/setting-up-a-new-installation/installation-wizard/ where among other things, you have to set pretty permalinks.

    If you did go through the Installation Wizard and you're using a WP theme, did you install/activate the BP Template Pack plugin and go through Appearance > BP Compatibility process? http://codex.buddypress.org/theme-development/wordpress-to-buddypress-theme/

  3. eleudson
    Posted 3 years ago #

    Hi, I resolve (ubuntu server 12.04, apache2) this problem as follow:

    1) Execute the setup wizar of BuddyPress after the plugin activate

    Tip from http://codex.buddypress.org/user/setting-up-a-new-installation/installation-wizard/

    2) Move the plugins\buddypress\bp-themes to wp-content/themes and set the pretty permalink. I’am using the month + name.

    Tip from http://wpmu.org/buddypress-now-supports-wordpress-single-user-no-wpmu-required/

    3) Set the Apache2 mod_rewrite with

    # sudo a2enmod rewrite

    and change the option AllowOverride of None to all in the file /etc/apache2/sites-avaliable/default

    Options Indexes FollowSymLinks MultiViews
    AllowOverride all

    Tip from http://www.lavluda.com/2007/07/15/how-to-enable-mod_rewrite-in-apache22-debian/

Topic Closed

This topic has been closed to new replies.

About this Topic