Support » Plugin: Yoast SEO » The rel nofollow and/or sponsored clears off after plugin update

  • Resolved diraph

    (@diraph)


    When creating/updating posts, I use(d) the rel=”nofollow” for external links I don’t want the search engine to follow.

    After the plugin update, all the links I added the nofollow removed by default. I didn’t even notice until I started editing some pages.

    Please if this is a bug, kindly fix it.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @diraph,

    We’re sorry to hear about the problem. To help us try to reproduce this, we’d like to get a bit more information:

    1. Can you let us know what versions of Yoast SEO and WordPress you were using before and after your update?

    2. Can you let us know what editor you’re using? Is this the default block editor or the Classic Editor? Did you add the links using any third-party page builder or shortcodes?

    3. How did you add the nofollow to the links? Did you use the Yoast SEO nofollow feature added in version 14.4 or did you add this by editing the anchor tag using the code editor?

    4. Can you give us an example page or links to screenshots that show the problem?

    Experiencing the same issue. Using latest versions with block editor and Yoast nofollow feature. The nofollow and sponsored attributes seem to stay in the code but the toggles are cleared every time the post is updated.

    Thread Starter diraph

    (@diraph)

    1. The latest version (14.9)
    2. The default block editor.
    3. This is happening to all pages with nofollow/sponsored alt. See sample here
    Please and please, this really hurts my SEO.

    Solve it!

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thank you for bringing this issue to our attention!

    We apologize for the trouble you are currently experiencing with our plugin. Luckily, a so-called “bug report” (a description of the issue, so we can fix it) is filed already.

    What’s next?
    Our product team will assess the severity of this problem in relation to other open bug reports and new features. Based on their assessment, the bug report will be given a priority. Our developers work on the highest priority issues first. Unfortunately, this means we cannot give you an estimate when they’ll start working on your report.

    If you have any further information that may affect the prioritization or help our development team solve this bug, please feel invited to reply to this forum topic.

    “nofollow” attribute has stopped working. But I noticed that it does not work with “noopener” and “noreferrer”. If you remove them, “nofollow” works. This may be a wordpress issue. Because the combination of “nofollow” “noopener” and “noreferrer” doesn’t work in the menu navigation either. (Sorry for Google translate)

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @mrftun,

    Thank you for chiming in.

    Yes, the bug report is still open and on our radar. We’re sorry that this takes a while, we don’t have any ETA or more information at this time. This has been logged and we’ll be seen by our product team. Thank you.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @diraph,

    We’re marking this issue as resolved due to inactivity. You’re welcome to create a new issue if you need further assistance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘The rel nofollow and/or sponsored clears off after plugin update’ is closed to new replies.