Support » Plugin: qTranslate » The qTranslate Editor has disabled itself because it hasn't been tested with you

  • Resolved linuskristensen

    (@linuskristensen)


    Hi all,

    I’m using Qtranslate 2.5.39 with WP 3.8.2
    The plugin is activated and no error message is seen. But on post and page writing page I get this message :

    The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.

    On the public website, no problem : languages work !
    Any idea ?

    https://wordpress.org/plugins/qtranslate/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Ok found it : I edited qtranslate.php and changed
    define('QT_SUPPORTED_WP_VERSION', '3.8.1');
    to
    define('QT_SUPPORTED_WP_VERSION', '3.8.2');

    Yeah! thx a lot for the hack.
    It would be nice including it on the message or, at least, the FAQ.

    Thx a lot now it works. 😀

    Should we have to do that fix at every minor update? 🙁

    I made the mistake of following this and now get

    `

    Warning: Cannot modify header information – headers already sent by ….etc

    I’d be careful using this hack. If you risk it, backup the above file first

    EDIT: I see why, it worked if edited through WP. Don’t edit via ftp as that breaks it

    i edited that “to define(‘QT_SUPPORTED_WP_VERSION’, ‘3.8.2’); and i dont see that message again, but now my Homepage doesnt display, i get this: Oops! we couldn’t find the page you requested, Go home?, when i desactivate the plugin, its appear again.

    GENIUS… Thanks for this little fix guys

    Hi, I’m new to WordPress. Anyway, I just got my first domain last week, got Qtranslate, everything worked perfectly until WordPress sent me an email saying that I was automatically upgraded to 3.8.2 Now qtranslate is all screwed up!!
    It looks like there’s a solution to this problem but I don’t know how to put it in place. Please help!

    Hey qTranslate developers!

    You need to take a new approach now that WordPress has started to auto update.

    Explicitly declaring the exact minor version of WP is not an option anymore!

    Maybe comparing the first two figures in the version number only is a better idea?

    best regards Johan

    this is the single most annoying thing about qtranslate, a plugin I use a lot and I like the way it works very much.

    to make things worse, this security feature has never worked correctly for me. The message is repeated 3 times. If I click “reenable” 2 messages still stay active and it is impossible to edit anything on the page. (does anyone else experience this?) Clients also get extremely irritated by this message and I have to risk losing client data each time (or wait days/weeks for the update).

    I hope WordPress developers will implement multi-language in its core in the near future. Or, at least, give advance notice to plugin developers if they plan to change the editor logics, so they don’t need to cripple the admin after each update.

    Johan, I don’t think that the author is monitoring this forum. Please contact the author here: http://www.qianqin.de/contact/

    Hey everyone, if you change the code from
    define('QT_SUPPORTED_WP_VERSION', '3.8.1');
    to
    define('QT_SUPPORTED_WP_VERSION', $wp_version);

    You won’t have to modify the file again for future versions. It does also mean there’s a risk it won’t be compatible and break itself / corrupt your data during a future auto-update, but what other choice do we have.

    joelmb

    I changed it through FTP, and now have same problem. How do I fix it?

    Thanks

    Fixed
    Warning: Cannot modify header information – headers already sent by
    by reinstalling qtranslate.

    Then edited qtranslate.php from WP dashboard editor, and now it works with 3.8.2. Don’t edit from FTP as stated aboce

    @mungous Beautiful hack!

    …change the code from
    define('QT_SUPPORTED_WP_VERSION', '3.8.1');
    to
    define('QT_SUPPORTED_WP_VERSION', $wp_version);

    …in qtranslate.php.

    Works great and I won’t have to edit it again next time a minor version of WP is released! Very nice.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘The qTranslate Editor has disabled itself because it hasn't been tested with you’ is closed to new replies.