Support » Plugin: Include Me » The provided file does not exist in the inclusion folder

  • rainer4th

    (@rainer4th)


    Hi Stefano,

    We have used include-me for years now without any problems. Suddenly it seems not to work any more. In the frontend nothing happens at all. In the backend (logged in as admin) the message is:

    The provided file (xxx.php) does not exist in the inclusion folder (wp-content/include-me – if not customized). This message is shown only to administrators.

    I have read all relevant posts but I cannot get it working again.

    Up to now we used the folder “wp-content/myphpfiles”, which had worked for years:

    [includeme file=”wp-content/myphpfiles/xxx.php”]

    Now I also tried starting with “/”:

    [includeme file=”/wp-content/myphpfiles/xxx.php”]

    Since the error message seems to request the folder “wp-content/include-me” I made a duplicate of the existing folder “myphpfiles” named “include-me” and also tried these:

    [includeme file=”wp-content/include-me/xxx.php”]
    [includeme file=”/wp-content/include-me/xxx.php”]

    Then I also tried with the absolute paths:

    [includeme file=”/www/htdocs/xxx/domain.com/wp-content/myphpfiles/xxx.php”]
    [includeme file=”/www/htdocs/xxx/domain.com/wp-content/include-me/xxx.php”]

    I even tried adding “define(‘INCLUDE_ME_DIR’, ‘*’)” to the config.php as suggested in one of the posts.

    Nothing works. Can you please tell me how to get it working again?

    Thank you,

    Rainer

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • craigs85

    (@craigs85)

    I have the same issue so I’m following this thread 👍

    christianboyce

    (@christianboyce)

    Same problem for me too, and the files I’m trying to include definitely exist in the proper location. Worked great until recently.

    craigs85

    (@craigs85)

    Add this to the wp-config file below the define dB lines.

    define(‘INCLUDE_ME_DIR’, ‘*’);

    christianboyce

    (@christianboyce)

    Thanks craigs85, I did what you (and the documentation) suggested even though I didn’t want to, and of course it works. I was hoping to make the default location work. But… since I have different sites referencing the same files (three sites, one set of files on one server) I think maybe it can’t work with a fixed, default location– not for me, with two sites pulling files from a third site. The third site could work with the default (if I made it work) but the others wouldn’t, I think.

    Thread Starter rainer4th

    (@rainer4th)

    Thank you craigs85, I tried once more

    define(‘INCLUDE_ME_DIR’, ‘*’);

    in wp-config.php. This time it works – after I removed the quotes ‘ and replaced them with ‘.

    However, I guess that ‘*’ allows to include files from any location. This may be not the safest option. I’d certainly prefer using the safer option to allow only a specific folder. But no matter how I enter the information, it does not work!

    I tried:

    define(‘INCLUDE_ME_DIR’, ‘wp-content/foldername’);
    define(‘INCLUDE_ME_DIR’, ‘/wp-content/foldername’);
    define(‘INCLUDE_ME_DIR’, WP_CONTENT_DIR.‘ foldername’);
    define(‘INCLUDE_ME_DIR’, WP_CONTENT_DIR.‘/foldername’);
    define(‘INCLUDE_ME_DIR’, ‘foldername’);
    define(‘INCLUDE_ME_DIR’, ‘/foldername’);

    To my disappointment the documentation on this is really poor.

    For now it seems I have no choice but to use the unsafe way.

    Rainer

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.