Support » Plugin: UpdraftCentral Dashboard » The process has been aborted due to an error

  • Resolved createscape

    (@createscape)


    Hello,
    I can queue updates but when I click on the process queue button, it says “The process has been aborted due to an error”. At the top of the page it says “Update Failed”.

    Thanks very much,
    Crystal

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi Crystal,

    If you check on the site, does it actually update? We’ve been seeing that we have the timeout too short currently, and that often it actually succeeds.

    Also – if you go into your browser’s developer console, it should show the details of the error – can you see what it says in there?

    David

    Hello,
    I checked the site and the plugins weren’t updated.

    This is what the console says:

    Uncaught ReferenceError: exports is not defined
        at sanitizer.min.js?ver=20150315:2
    bootstrap.min.js?ver=4.0.0-alpha5:7 Uncaught Error: Bootstrap tooltips require Tether (http://tether.io/)
        at bootstrap.min.js?ver=4.0.0-alpha5:7
        at bootstrap.min.js?ver=4.0.0-alpha5:7
        at bootstrap.min.js?ver=4.0.0-alpha5:7
    
    Plugin Author David Anderson

    (@davidanderson)

    Hi Crystal,

    Can you give this version a try? It is our upcoming release, which may fix this problem: https://downloads.wordpress.org/plugin/updraftcentral.zip

    David

    Hello David,
    I’ve installed the new version of your plugin but it didn’t work. I still get the same error, although the console error messages have changed:

    sanitizer.min.js?ver=20150315:2 Uncaught ReferenceError: exports is not defined
        at sanitizer.min.js?ver=20150315:2
    bootstrap.min.js?ver=4.0.0-alpha5:7 Uncaught Error: Bootstrap tooltips require Tether (http://tether.io/)
        at bootstrap.min.js?ver=4.0.0-alpha5:7
        at bootstrap.min.js?ver=4.0.0-alpha5:7
        at bootstrap.min.js?ver=4.0.0-alpha5:7
    dashboard.min.js?ver=0.6.0:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.0:2 Objectplugins: Array(1)__proto__: Object

    I am using WordPress Multisite. Do you think that makes any difference? The plugin isn’t network activated, only on the single site.

    Thanks,
    Crystal

    Plugin Author David Anderson

    (@davidanderson)

    Hi Crystal,

    Thank you. This seems to be a different problem, but probably related to the fix.

    Which web browser are you using? If it’s Firefox, can you open the full Developer Tools window instead of just the console? And then, whichever browser it is, click on the last error message (“the submitted data parameter contains unserializable types”) to get the full display of the problematic object?

    Our developers will also be trying to work it out by looking at the code. But with the above, that will help us go quicker. Or, if you prefer, I can give you an email address that you could send login details to so that we could look directly.

    David

    Plugin Author David Anderson

    (@davidanderson)

    Also – what is the plugin that you are trying to update when this happens? Is it from wordpress.org or somewhere else?

    We have not yet managed to reproduce this problem. If we could get a screenshot of the Developer Tools in your browser, with all the details of the object relating to the last line in the log in your previous message, that should help us to fix it.

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    We’ve just released UpdraftCentral 0.6.1, which is the result of lots of work in investigating corner-cases and trying to provoke issues in the updates system, and has lots of tweaks/fixes in it. Please can you give it a try and let us know how you get on?

    David

    Hello,
    Thank you, however it is still not working. There are some new error messages in the console:

    
    dashboard.min.js?ver=0.6.1:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.1:2 Error field: compare
    dashboard.min.js?ver=0.6.1:2 Error type: function
    dashboard.min.js?ver=0.6.1:2 Error value follows:
    dashboard.min.js?ver=0.6.1:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    dashboard.min.js?ver=0.6.1:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.1:2 Error field: compare
    dashboard.min.js?ver=0.6.1:2 Error type: function
    dashboard.min.js?ver=0.6.1:2 Error value follows:
    dashboard.min.js?ver=0.6.1:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    dashboard.min.js?ver=0.6.1:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.1:2 Error field: compare
    dashboard.min.js?ver=0.6.1:2 Error type: function
    dashboard.min.js?ver=0.6.1:2 Error value follows:
    dashboard.min.js?ver=0.6.1:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    dashboard.min.js?ver=0.6.1:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.1:2 Error field: compare
    dashboard.min.js?ver=0.6.1:2 Error type: function
    dashboard.min.js?ver=0.6.1:2 Error value follows:
    dashboard.min.js?ver=0.6.1:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Thank you. That should be enough information for us to fix it. This latest release increased the amount of information when updates fail. I will get back to you.

    David

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Please can you try again, with the just-released 0.6.2?

    David

    Hi David,
    Sorry, it’s still not working. Here are the new console errors:

    UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.2:2 Error field: compare
    dashboard.min.js?ver=0.6.2:2 Error type: function
    dashboard.min.js?ver=0.6.2:2 Error value follows:
    dashboard.min.js?ver=0.6.2:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    dashboard.min.js?ver=0.6.2:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.2:2 Error field: compare
    dashboard.min.js?ver=0.6.2:2 Error type: function
    dashboard.min.js?ver=0.6.2:2 Error value follows:
    dashboard.min.js?ver=0.6.2:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    updates.min.js?ver=0.6.2:2 Uncaught TypeError: Cannot read property 'focus' of null
        at HTMLAnchorElement.<anonymous> (updates.min.js?ver=0.6.2:2)
        at HTMLDivElement.dispatch (jquery.min.js:5)
        at HTMLDivElement.v.handle (jquery.min.js:5)
    dashboard.min.js?ver=0.6.2:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.2:2 Error field: compare
    dashboard.min.js?ver=0.6.2:2 Error type: function
    dashboard.min.js?ver=0.6.2:2 Error value follows:
    dashboard.min.js?ver=0.6.2:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    dashboard.min.js?ver=0.6.2:2 UpdraftCentral: send_site_rpc(updates.do_updates) - the submitted data parameter contains unserializable types (follows)
    dashboard.min.js?ver=0.6.2:2 Error field: compare
    dashboard.min.js?ver=0.6.2:2 Error type: function
    dashboard.min.js?ver=0.6.2:2 Error value follows:
    dashboard.min.js?ver=0.6.2:2 function (d){if(this.length!=d.length)return!1;for(var b=0;b<d.length;b++)if(this[b].compare&&
    !this[b].compare(d[b])||this[b]!==d[b])return!1;return!0}
    Plugin Author David Anderson

    (@davidanderson)

    Hi Crystal,

    Is this in the ‘Updates’ screen for a single site, or in the ‘updates for all sites’ screen? What is the name of the plugin being updated? Is it from wordpress.org, or is it third-party?

    We’d been assuming that it was on the ‘updates for all sites’ screen, and the previous fixes targeted that… but perhaps it is not?

    David

    Hello,
    Sorry for the delay in writing back to you. I re-designed my site and launched it this week. I just re-installed the Updraft Dashboard and the updates worked fine, without any errors.
    The plugins were all from WordPress.org. I was using the Updates link in the left hand side menu.
    Thank you for your help. I’m marking this as resolved.

    Plugin Author David Anderson

    (@davidanderson)

    Hi,

    Great – glad that it works. A bit strange that it works, as in theory removing the plugin and installing again doesn’t change anything. But still, if it works now, then all is well!

    David

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘The process has been aborted due to an error’ is closed to new replies.