Support » Plugin: Markup by Attribute for WooCommerce » the price of variations does not change

  • Resolved akr16

    (@akr16)


    Hi!
    I have a problem. I added markups and they are displayed in the product. But when I create variations and select a base price, all the variations take the base price. And the markup is indicated in the options, but it does not change the price in the cart

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Mark Tomlinson

    (@marktomlinson)

    I can’t figure out how to reproduce this problem. I assume, from the way you phrased it, that you are using Set regular prices to set the base price, and that there is a product variation for each of the attribute terms that have a markup. Is this correct?

    If there is an ‘Any’ variation for the attribute with the markup, WooCommerce will always select that one when displaying to the customer, and the marked up price will not be presented to them. However, you say “all the variations take the base price,” which implies you are talking about the product edit page rather than the customer view. So, that doesn’t sound like the issue either.

    All I can ask at this point is whether you can enable the debug.log in WordPress to see if any errors are thrown. Or, if you think you might have another plugin that may hook into the Set regular prices function and override Markup-by-Attribute?

    Thread Starter akr16

    (@akr16)

    I have many attributes (30), and have markups
    Picture:
    https://wampi.ru/image/RsD5dFJ

    But when I select Set regular prices, all prices take base price and ignoring markups

    2021/08/22 09:01:34 [warn] 20051#20051: *58188604 an upstream response is buffered to a temporary file /tmp/nginx_proxy_temp/0000509046 while reading upstream, client: 99.76.12.3, server: site.ru, request: “GET /wp-admin/post.php?post=329&action=edit HTTP/2.0”, upstream: “http://127.0.0.1:8080/wp-admin/post.php?post=329&action=edit”, host: “site.ru”, referrer: “https://site.ru/wp-admin/edit.php?post_type=product”

    Plugin Author Mark Tomlinson

    (@marktomlinson)

    That appears to be one attribute with about 30 options (Without painting, Designer stains, Varnish, etc.). Thirty options should not be a problem, I just tested with 392 product variations.

    • About how many product variations do you have for each product?
    • How did you create the product variations?
    • If you have other plugins that affect the attributes, have you tried disabling them (just to test)?
    • Have you attempted to reinstall Markup-by-Attribute?

    The error message indicates that there was a caching problem with NGINX, and is unrelated to Markup-by-Attribute (https://www.google.com/search?q=an+upstream+response+is+buffered+to+a+temporary+file+%2Ftmp%2Fnginx_proxy_temp%2F+while+reading+upstream%2C+client).

    Thread Starter akr16

    (@akr16)

    I have not other plugins.
    Can you check Worpress version 5.8 Theme: vdequator version: 1.1.4 maybe conflict with theme?

    Plugin Author Mark Tomlinson

    (@marktomlinson)

    I installed Vdequator, its parent theme, Busiprof, and its recommended plugin, Webriti Companion. My testing still showed no problems. This is what I expected because themes generally do not affect the admin screens.

    • About how many product variations do you have for each product?
    • How did you create the product variations?
    • Have you attempted to reinstall Markup-by-Attribute?
    Thread Starter akr16

    (@akr16)

    Hi! Thank you for help. I found problem. This does not work with Russian labels. I changed labels to English and all is good
    https://wampi.ru/image/RssBdt4 – this label

    Plugin Author Mark Tomlinson

    (@marktomlinson)

    Wow, it should work with any language! That sounds like something I’ll have to look into.

    Glad you got it working.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.