Support » Plugin: Translate Multilingual sites - TranslatePress » The Post trp-ajax.php took 6.3 seconds to load

  • Resolved faraway1215

    (@faraway1215)


    Hi, I’ve tested translatepress for quite a few weeks now, and I love it. Definitely is looking forward for pro version to extend the language availabilities. But I’ve found out that every single time when I tried to translate the page, which I understand it must come from an ajax PHP, but lets say my audience is viewing in Taiwanese. from that point on, when the page appears in Taiwanese and so forth onto the other pages, I found out that the trp-ajax.php will take more than 5 seconds to finish loading on every further pages. which causes the “contact us” form a tremendous amount of time to have the form appear after 6 seconds (with the URL above pasted) testing from GT metrix. Is there a way to reduce the amount of time being loaded? or is there any settings to reduce the time. We are using Elementor as the main builder. Thank you.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support andrei202

    (@andrei202)

    Greetings,

    Thanks for getting in touch about your problem.

    It’s possible that you have duplicate entries in your database. You can use the Remove duplicate rows option from TP Settings –> Advanced tab to clear them.

    If that doesn’t do anything you can try turning off Force language in custom links and Use subdirectory for default language.

    Let me know if this improves your loading speed.

    Regards.

    Thread Starter faraway1215

    (@faraway1215)

    Hi Andrei,
    Thanks for getting back to me, I’ve tried the above techniques you’ve recommended, but none of them speed things up. Are there any other ways to get around this?
    Currently, when using the Taiwanese translated site, the site itself loads fast, the screen will be scrollable, but none clickable until the gravity form on the site shows up, which is after 10 seconds.

    Thread Starter faraway1215

    (@faraway1215)

    FYI, sorry for the delay on this related info, that I thought it’d be important.
    I was using GTmetrix for the above tests and with waterfall guides. It seems that the “POST trp-ajax.php” didn’t load on time until 10 seconds later, while everything was loaded up within 3 seconds, except for this specific PHP file. Thanks.

    Plugin Support andrei202

    (@andrei202)

    Hello there,

    We deeply apologize for the delayed response.

    There has been a great load on our support team in the past few days, but such a long reply time is very uncommon.

    You could do a quick test by disabling Dynamic String Translation in TranslatePress -> Settings -> Advanced

    Then check the homepage and make sure everything is still translated.

    If it is, you could probably leave it like this. Otherwise, you’ll probably need to exclude certain elements from Dynamic String Translation that don’t do anything for you anyway. You can do that from the same settings page.

    Let me know how this works out.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.