Support » Plugin: PHP Compatibility Checker » The plugin/theme was skipped as it was too large to scan before the server kille

  • Have this result for a number of plugins but server is an average dedicated server. Upped timeout to 1500 in wp-config but that didn’t help. Any other tweaks that can be done so that this plugin can evaluate all plugins?

Viewing 11 replies - 1 through 11 (of 11 total)
  • We had the same issue – skipped the whole site themes, plugins…server killed every time.

    Did you guys find out a solution for this? Same thing is happening for me today check PHP 7.1. Theme (HealthMedical WPL from WPLook) and 7 plugins, most of which are pretty common (i.e. TinyMCE, Duplicator, Classic Editor)

    Any help is greatly appreciated.

    MD

    I get this message, but only for the Analytify plugin.

    Would appreciate some guidance.

    Thanks!

    davidvee

    (@davidvee)

    WPEngine Employee

    Hello all. This is David with WP Engine here. We have a team currently working on the hang up issue related to certain plugins as well as adding support for PHP 7.3.

    We expect the update in weeks, not months.

    Sorry for the delay on this. We’ve shored up our maintenance resources here to keep up with updates, bug fixes, and support tickets more aggressively moving forward.

    Thanks for your patience, and please let us know if you have any more questions or comments.

    Can anyone recommend another plugin? Our Development site is hosted in-house and we currently sit on PHP 5.4.45. We tried to upgrade to php7 and added the mysqli_init and the site broke.
    Fatal error: Uncaught Error: Call to undefined function mysqli_init() in C:\inetpub\wwwroot\wp-includes\wp-db.php:1509 Stack trace: #0
    C:\inetpub\wwwroot\wp-includes\wp-db.php(592): wpdb->db_connect() #1 C:\inetpub\wwwroot\wp-includes\load.php(404): wpdb->__construct(‘wordpressuser10…’, ”, ”, ”) #2 C:\inetpub\wwwroot\wp-settings.php(106): require_wp_db() #3 C:\inetpub\wwwroot\wp-config.php(103): require_once(‘C:\\inetpub\\wwwr…’) #4 C:\inetpub\wwwroot\wp-load.php(37): require_once(‘C:\\inetpub\\wwwr…’) #5 C:\inetpub\wwwroot\wp-blog-header.php(13): require_once(‘C:\\inetpub\\wwwr…’) #6 C:\inetpub\wwwroot\index.php(17): require(‘C:\\inetpub\\wwwr…’) #7 {main} thrown in C:\inetpub\wwwroot\wp-includes\wp-db.php on line 1509

    • This reply was modified 1 year, 1 month ago by rudyarnold.
    • This reply was modified 1 year, 1 month ago by rudyarnold.

    @davidvee – any updates on this?

    We are planning to upgrade PHP to 7.3. So when I run the PHP compatibility plugin, I get the same message “The plugin/theme was skipped as it was too large to scan before the server killed the process.” for ManageWP – Worker – Unknown and
    Next Active Directory Integration – plugins. Any suggestions on how to fix this.

    Thank you,
    Leila

    Scan Results for PHP 7.2 Compatibility:
    The plugin/theme was skipped as it was too large to scan before the server killed the process. Any resolution?

    @davidvee it has been months not weeks but we have still this issue. Any update on this?

    davidvee

    (@davidvee)

    WPEngine Employee

    Hello @ilmigo. Sorry for the delay on this front. After a ton of research on what is causing certain scans to hang, we’ve determined that the plugin is hanging most often due to environment conditions on the servers where the scans are being run vs. the plugin itself or certain types of code it scans causing the problem.

    This means that there is no clean way to code around the problem within the plugin. We’re currently exploring options for “side linting” (e.g. offloading the linting from your server/computer to an external service). That approach would require ongoing server costs, authentication systems, abuse controls, etc (as would any external computing service), so we’re taking a look at how viable that would be for us in this scenario.

    Our recommendation at this point is if the plugin is hanging during a scan, that you try the scan in a different environment (e.g. locally, etc.). I like to use https://localbyflywheel.com/ for local environments. For full disclosure Flywheel was purchased by WP Engine last year so of course I would like their local dev product 🙂

    As previously mentioned, it’s always preferential to run the scans on a non-production server anyways (hangs or no hangs).

    There are other tools / options for linting for PHP version compatibility that require more technical ability than is required with this plugin, so we’re planning to update documentation on the plugin to reference these alternative methods should users of the plugin experience a hanging scan.

    Right now we’re focused on getting support for 7.4 support out the door and we’ll be coming back to documentation updates and looking deeper at the side linting option.

    If you could just tell me if there is a config setting that can be used to temporarily permit this too work. Just what setting is too small/low for this to complete?

    Hi @davidvee, can you tell us please what the environment conditions need to be on the test server where we are running this plugin. I have copied my clients site to my test server, and am getting this error message. I increased max_execution_time in php.ini to 3000 (50 minutes), and after 20 minutes all 15 plugins were scanned and all had this error message against them. Just how should we set up a test environment for this plugin to work?

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.