Support » Plugin: GSheet For Woo Importer » the plugin stopped working

  • Resolved Carlos Silva

    (@kbzati)


    Greetings, thanks for share this excellent plugin, i was using it and suddenly stopped working. No show me this error:

    We can’t set connection with google API by your provided credentials, Please check your setting and internet connection and try again. Error: (GSWOO\Services\SheetInterplayService::set_api_connect) You need permission.

    i’d appreciate it if you could help me with this error, excuse my english but its not my native language

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author OlegApanovich

    (@mrdollar4444)

    Hi Carlos thanks for your bag reportings.
    As I can undestarstand right now you are using plugin verstion 2.0.3 ?

    Seems like there something changed with google API connection and I must add some changes in plugin too. In my next weekend I try to figure it out and let you know.

    Hi Oleg,

    I also have this problem (with the same error) with one of my two websites using your plugin!
    (version 2.0.3)

    Plugin Author OlegApanovich

    (@mrdollar4444)

    Trying to fix it as soon as possible.
    When I figure it out, I let you know in this topik

    I’m also seeing this issue on my website.

    Thank you for all your hard work Oleg! I really appreciate it!

    Plugin Author OlegApanovich

    (@mrdollar4444)

    Thanks for report, in the next weekend I planing to fix it. This plugin is non profit project, and I can develop it only in my free time, hope for undestanding.

    Plugin Author OlegApanovich

    (@mrdollar4444)

    The Google Sheets v3 API was shut down on August 2, 2021.
    We need to migrate to v4. I try to migrate this plugin as soon as possible and let you know about that in this topick.

    Plugin Author OlegApanovich

    (@mrdollar4444)

    Problem fixed with new version plugin 2.1.1 that was release today.
    Please note it a creatical update. All previous version of plugin before 2.1.1 stop working
    It happen becouse Google shut down v3 API on August 2 , 2021 all plugin verstions before 2.1.1 was base on it.

    Right now plugin base on Google API v4 API with json format compatible.

    kasparsmime

    (@kasparsmime)

    Hi Oleg,
    I actually had this error today after updating to v.2.1.1
    Error:
    (GSWOO\Services\SheetInterplayService::get_sheet_csv) { “error”: { “code”: 400, “message”: “Unable to parse range: File name”, “errors”: [ { “message”: “Unable to parse range: File name”, “domain”: “global”, “reason”: “badRequest” } ], “status”: “INVALID_ARGUMENT” } }

    It went back to normal when I reverted it back to 2.0.3.
    What shall I do to make the 2.1.1. work?
    Thanks.

    Plugin Author OlegApanovich

    (@mrdollar4444)

    Hi @kasparsmime thanks for your bag report.
    Seem like it new error do not related to error resolved in this topic.
    Can you please provide more info about your google api connection type.
    It can be “One click auto connect” or “Manual connect” info about it you can find on plugin settings page https://i.imgur.com/bcodZDf.png
    Also it will be very helpfull if you can provide me your google sheet file that you use with your imprort process.
    You can send me it to my email dollar4444@gmail.com or share to me by my email.

    Plugin Author OlegApanovich

    (@mrdollar4444)

    Fixed this issue too
    Error:
    (GSWOO\Services\SheetInterplayService::get_sheet_csv) { “error”: { “code”: 400, “message”: “Unable to parse range: File name”, “errors”: [ { “message”: “Unable to parse range: File name”, “domain”: “global”, “reason”: “badRequest” } ], “status”: “INVALID_ARGUMENT” } }

    With plugin new verstion 2.2.0
    Please update.

    Amazing work Oleg, thank you so much!
    I tested it and it works! Much appreciated!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.