Support » Plugin: WooCommerce Product Image Flipper » The plugin is not working on my website

Viewing 6 replies - 1 through 6 (of 6 total)
  • I add this css to work with my theme:

    ul.products li.pif-has-gallery .post_featured a:hover .wp-post-image {
    	opacity: 0;
    }
    
    ul.products li.pif-has-gallery .post_featured a:hover .wp-post-image--secondary {
    	opacity: 1;
    }
    
    ul.products li.pif-has-gallery .post_featured a [class*="wp-post-image"] {
    	-webkit-transition: opacity .5s ease;
    	-o-transition: opacity .5s ease;
    	transition: opacity .5s ease;
    }

    Please tell me how it can work on my theme.

    You solution is not working on my theme

    Your html structure differs from the standard woocommerce.

    First, u need to have two images inside the “a” tag like this:

    https://gyazo.com/6def5a6995a6d35fc24b82a31aa16029

    ¿U have the plugin activated?

    Yes, I have activated the plugin. I don’t know how to place these 2 image inside the “a” tag.

    Could you please help me to fix this?

    Thank you

    The problem based on your theme.

    This is a sample of product loop

    <?php
    /**
     * The template for displaying product content within loops.
     *
     * Override this template by copying it to yourtheme/woocommerce/content-product.php
     *
     * @author 		WooThemes
     * @package 	WooCommerce/Templates
     * @version	 1.6.4
     */
    
    if ( ! defined( 'ABSPATH' ) ) exit; // Exit if accessed directly
    
    global $product, $woocommerce_loop;
    
    // Store loop count we're currently on
    if ( empty( $woocommerce_loop['loop'] ) )
    	$woocommerce_loop['loop'] = 0;
    
    // Store column count for displaying the grid
    if ( empty( $woocommerce_loop['columns'] ) )
    	$woocommerce_loop['columns'] = apply_filters( 'loop_shop_columns', 4 );
    
    // Ensure visibility
    if ( ! $product || ! $product->is_visible() )
    	return;
    
    // Increase loop count
    $woocommerce_loop['loop']++;
    
    // Extra post classes
    $classes = array();
    if ( 0 == ( $woocommerce_loop['loop'] - 1 ) % $woocommerce_loop['columns'] || 1 == $woocommerce_loop['columns'] )
    	$classes[] = 'first';
    if ( 0 == $woocommerce_loop['loop'] % $woocommerce_loop['columns'] )
    	$classes[] = 'last';
    ?>
    <li <?php post_class( $classes ); ?>>
    
    	<?php do_action( 'woocommerce_before_shop_loop_item' ); ?>
    
    	<a href="<?php the_permalink(); ?>" class="product-images">
    
    		<?php
    			/**
    			 * woocommerce_before_shop_loop_item_title hook
    			 *
    			 * @hooked woocommerce_show_product_loop_sale_flash - 10
    			 * @hooked woocommerce_template_loop_product_thumbnail - 10
    			 */
    			do_action( 'woocommerce_before_shop_loop_item_title' );
    		?>
    
    	</a>
    
    	<div class="product-details">
    
    		<div class="product-details-container">
    
    			<h3 class="product-title"><a href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h3>
    
    			<div class="clearfix">
    
    				<?php
    					/**
    					 * woocommerce_after_shop_loop_item_title hook
    					 *
    					 * @hooked woocommerce_template_loop_price - 10
    					 */
    					do_action( 'woocommerce_after_shop_loop_item_title' );
    				?>
    
    			</div>
    
    		</div>
    
    	</div>
    	
    	<?php do_action( 'woocommerce_after_shop_loop_item' ); ?>
    
    </li>

    Did you specify the woocommerce hooks on your theme?

    This plugin use “woocommerce_before_shop_loop_item_title” to add the second image

    I really appreciate your time and effort to resolve my issue.

    I know that the problem is with my theme. When I switch to another theme the plugin is working fine.

    Below is code of content-product. Could you please modify this for me?

    <?php
    /**
     * The template for displaying product content within loops
     *
     * This template can be overridden by copying it to yourtheme/woocommerce/content-product.php.
     *
     * HOWEVER, on occasion WooCommerce will need to update template files and you
     * (the theme developer) will need to copy the new files to your theme to
     * maintain compatibility. We try to do this as little as possible, but it does
     * happen. When this occurs the version of the template file will be bumped and
     * the readme will list any important changes.
     *
     * @see     https://docs.woocommerce.com/document/template-structure/
     * @author  WooThemes
     * @package WooCommerce/Templates
     * @version 3.0.0
     */
    
    if ( ! defined( 'ABSPATH' ) ) {
    	exit; // Exit if accessed directly
    }
    
    global $product;
    
    // Ensure visibility
    if ( empty( $product ) || ! $product->is_visible() ) {
    	return;
    }
    ?>
    <div <?php post_class(); ?>>
    <div class="imgfiled">
    	<?php
    	/**
    	 * woocommerce_before_shop_loop_item hook.
    	 *
    	 * @hooked woocommerce_template_loop_product_link_open - 10
    	 */
    	do_action( 'woocommerce_before_shop_loop_item' );
    
    	/**
    	 * woocommerce_before_shop_loop_item_title hook.
    	 *
    	 * @hooked woocommerce_show_product_loop_sale_flash - 10
    	 * @hooked woocommerce_template_loop_product_thumbnail - 10
    	 */
    	do_action( 'woocommerce_before_shop_loop_item_title' );
    ?>
    </div>
    <div class="protitle">
    	 <a href="<?php the_permalink(); ?>" class="collection_title">
    		<?php the_title(); ?>
    	</a>
    </div>
    <div class="rupeesrow">
    <?php
    	/**
    	 * woocommerce_after_shop_loop_item_title hook.
    	 *
    	 * @hooked woocommerce_template_loop_rating - 5
    	 * @hooked woocommerce_template_loop_price - 10
    	 */
    	do_action( 'woocommerce_after_shop_loop_item_title' );
    	?>
    </div>
    
    <div class="addbtnlink"> 
    <?php
    	/**
    	 * woocommerce_after_shop_loop_item hook.
    	 *
    	 * @hooked woocommerce_template_loop_product_link_close - 5
    	 * @hooked woocommerce_template_loop_add_to_cart - 10
    	 */
    	do_action( 'woocommerce_after_shop_loop_item' );
    	?>
    </div>
    </div>
    
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘The plugin is not working on my website’ is closed to new replies.