Support » Plugin: WP Subdomains (Revisited) » The plugin doesn't work if Subdomain Roots as Indexes is not marked

  • Hi there!

    I am more than happy to see that this awesome plugin is still maintained but .. It’s not working as it should be.

    I’ve tried it with Twenty Eleven, Twenty twelve, custom theme 3 versions of wordpress 3.5.1, 3.4, 3.3. I’ve tried even lower version 0.8 of the plugin – still no joy.

    The plugin only works if you’ve marked “Subdomain Roots as Indexes”. If it’s not – no matter on which subdomain you are, you will get the front page. I’ve activated it for all the categories. For example:
    1) Category A and Category B
    2) Post 1, Post 2 in Category A
    3) Post 3 in Category B

    No matter if I am on the main page or in any of the subdomains – it still gives me the 3 posts, so it must be some kind of problem in the mysql queries that the plugin does.

    Many of the themes have layout buildes integrated with them. With “Subdomain Roots as Indexes” activated with such a theme, I can only see the index too.

    So for now I think the plugin is broken.

    http://wordpress.org/extend/plugins/wp-subdomains-revisited/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author lontongcorp

    (@lontongcorp)

    So how do you expect it works “as it should be”?
    Screenshots would be great if you have the original version (with wp 2.7), assuming “working as it should be” = original version.
    Sorry to say but I was not investigating this feature deeper before because queries works as I expected for my needs.

    I have no intentions to support custom layout builders, so you should contact the theme developer (or any professionals) to handle it.
    If you a theme developer, just consider to work with archive templates in index file:

    is_category
    is_archive
    etc

    First of all I appreciate your efforts to give the community a working version of the plugin. Maybe I haven’t made myself clear. Sorry about that.

    The tick on Subdomain Roots as Indexes means that the plugin won’t use the archive template, but the home page of the template for every subdomain right? I am saying if it’s not marked – no matter what template you are using, even the default one. You’ll get all the posts in every subdomain no matter on which category you are.

    Here are some screenshots

    Index page
    Subdomain Test 1
    Subdomain Test 2

    As you can see every subdomain shows all the posts, not as it’s it is in the category archive of the page without the plugin.

    Test post 1 should be only visible in test1 subdomain and Test post 2 should be only visible in test2 subdomain. This is not a problem with the custom layout builders, because this is one of the default themes with wordpress – Twenty Eleven

    So I thought it was something with the queries, because if you tick the “Subdomain Roots as Indexes” option it would filter the posts and will show me only the posts for a specific categories, so it’s something with the query with the archive templates that the plugin do.

    Plugin Author lontongcorp

    (@lontongcorp)

    I see what you mean 😉

    Basically, without ticking “Subdomain as Root” it will use main index and behave like main domain. If the option enabled, then the content’s filter will apply.
    For the theme, archive.php/category.php will be applied only for sub-category for the subdomain category.
    Ex.:
    Test1 as Subdomain
    Test2 as child category of Test1

    So the category/archive php will be applied for http://test1.domain.com/category/test2 for example.

    If you really want test1 subdomain behave like category/archive php, you can consider a new theme (duplicate it with category/archive php as index.php) and apply that as custom theme for test1.

    Hi there!

    I’ve tried everything you’ve proposed but still no joy. What happens is when I put the tick on “Subdomain Roots as Indexes” – the main menu disappear.

    You can see it live currently at provik dot bg. I have two categories with two posts test1(post) in test1(category) and test2(post) in test2(category). The menu shows correctly in the main domain but not in the categories, but it show when you enter in the post – for ex. test1 post.

    Moreover if I put debug mode to true I see lot’s of errors:

    Notice: Trying to get property of non-object in /***/public_html/wp-content/plugins/wp-subdomains-revisited/plugin/classes.php on line 437
    
    Notice: Trying to get property of non-object in /***/public_html/wp-content/plugins/wp-subdomains-revisited/plugin/classes.php on line 438
    
    Notice: Trying to get property of non-object in /***/public_html/wp-content/plugins/wp-subdomains-revisited/plugin/classes.php on line 439

    How the plugin worked before it was revisited:
    When you activate the plugin and put the option for categories to be subdomains – it would make every category on its subdomain asking the template to give the category.php template for the corresponding category so if you are in test1 category, you will see only posts from test1. If you mark “Subdomain Roots as Indexes” it would give you only posts from test1 category but it would use index.php of the template, instead of category.php

    If you would like I could setup test installation with old wordpress and the old version of the plugin?

    Thank you for your replies!
    Regards,
    Krasen

    So here is the old versions – fmag1.com
    Wordpress 2.9
    Wordpress subdomains 0.6.9

    In the admin panel the only option I’ve selected is “Make all Subdomains” and when you select from the sidebar one of the categories, you get the archive template.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The plugin doesn't work if Subdomain Roots as Indexes is not marked’ is closed to new replies.