Support » Plugin: AdSense Invalid Click Protector (AICP) » The plugin doesn’t seem to set the cookie

  • Dear Support,

    I’ve added the AICP plugin to my WP project.

    We’re running PHP v7.2.11.

    Then I’ve changed my widget into a “PHP Code” widget and integrated this coding:

    <?php
    
    if( aicp_can_see_ads() ) {
    
    // Shows the ad
    
    echo '<div class="aicp">
    
    <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    <!-- mesho right side ad -->
    <ins class="adsbygoogle"
         style="display:inline-block;width:300px;height:250px"
         data-ad-client="ca-pub-1230039237937524"
         data-ad-slot="3542418401"></ins>
    <script>
    (adsbygoogle = window.adsbygoogle || []).push({});
    </script>
    
    </div>';
    
    } else {
    
    // Shows something if the user is blocked from seeing the ads
    
    echo '<p>Sorry! You are blocked from seeing ads.</p>';
    
    }
    
    ?>

    The PHP logic works and I’ve seen that by switching the php echos.

    However, clicking more than the 3 times defined on the settings does nothing.

    For testing purposes I’ve added also the “Ad Inserter” plugin and I’ve added the same coding on the “Block 1”, making sure that it is set as a “PHP” block and setting it to appear after the content.

    This other AD shows up, but again one could click it many more times than the number defined.

    What I see is that no cookie seems to be created.

    I’ve now lowered the number of allows clicks from 3 to 2 because yesterday we’ve tested it with 16 clicks and we risk to be suspended.

    Any idea what’s wrong?

    Let me add that we’ve also disabled all the other plugins, but it made no difference.

    What could prevent the cookie from being created?

    Basically the clicks are not tracked and consequently no user gets banned!

    Many thanks,
    Mihai

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘The plugin doesn’t seem to set the cookie’ is closed to new replies.