Support » Plugin: Weaver Show Sliders » The plugin does not have a valid header.

  • Resolved beautypeakwebdesign

    (@beautypeakwebdesign)


    I just tried to install this plugin but when I attempt to activate the plugin I get the error msg: “The plugin does not have a valid header.” My WordPress, Weaver XTreme theme and all plugins are all updated. I downloaded the plugin twice to make sure that the file wasn’t corrupted. My WordPress installation is running on my Apache2 local server installed on Ubuntu 14 Gnome. Help. Thank you.

    https://wordpress.org/plugins/show-sliders/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author wpweaver

    (@wpweaver)

    All plugins in the WP repository are automatically generated by WordPress, and not the theme authors.

    But, I am getting the same message, so there must be a corrupted .zip file stored on the WP plugin repository. I will try to generate a new version to see if that fixes the problem.

    Plugin Author wpweaver

    (@wpweaver)

    Follow up:

    Not sure what the issue is – but it might be a WP 4.4 bug. Will follow up.

    But there is an easy work around – upload and install the Show Sliders plugin as usual (current version is 1.3.4). Instead of trying to activate from the Plugin Uploader, instead activate from the “Installed Plugins” page. Then it works fine.

    Plugin Author wpweaver

    (@wpweaver)

    This is fixed in Show Sliders 1.3.5.

    It was due to what I consider a bug in WP 4.4.

    The direct cause was a change in the TGM Plugin Activation library that Show Sliders uses and updated versions recently. That change uncovered the bug in WP.

    It could also be considered a bug in TGMPA.

    Either way, there was a code work-around, and 1.3.5 fixes it.

    Thread Starter beautypeakwebdesign

    (@beautypeakwebdesign)

    Thanks much, that took care of it!

    Thread Starter beautypeakwebdesign

    (@beautypeakwebdesign)

    And also, thanks for creating the best damn WordPress theme around!!!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The plugin does not have a valid header.’ is closed to new replies.