WordPress.org

Support

Support » Plugins and Hacks » All-in-One Event Calendar » The plugin does not have a valid header.

The plugin does not have a valid header.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Open the file all-in-one-event-calendar.php in the root of the plugin and replace the comments on the first lines (which go from the /** to the */) with this

    /*
    * Plugin Name: All-in-One Event Calendar by Timely
    * Plugin URI: http://time.ly/
    * Description: A calendar system with month, week, day, agenda views, upcoming events widget, color-coded categories, recurrence, and import/export of .ics feeds.
    * Version: 1.9
    * Author: Timely
    * Author URI: http://time.ly/
    * License: GPL2
    */

    Don’t leave any space before that, just the <?php opening

    I actually don’t know if the licence is gpl2 but I added it because the header seems to need it.

    Thanks you.

    But why is this happening with a current version available for download from both the author’s site and the WP Plugins repository?

    It’s not like this is a new plugin.

    Hmm, I am having the same problem and I tried the fix above (thank you for it!) but when I tried to activate the plugin I am getting the following error:

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /all-in-one-event-calendar/app/controller/class-ai1ec-themes-controller.php on line 341

    Does anyone know how to fix this?!

    rosyb:

    either open up wp-config.php and put this in there:

    define('WP_MEMORY_LIMIT', '64M');

    or open up .htaccess in your web root and put this in there:

    php_value memory_limit 64M

    Thanks for the solution jphase!

    Ian,
    Thanks for publishing that fix. Still, this doesn’t inspire confidence. 🙂

    First the weird non-WP standards folder, now this. Hmmm. We’ll see if things simmer down or not, I guess.

    Worked for me, thanks!

    Working good…………Thanks…….

    All I did was change the initial /** to /*
    Then I went back and reactivated it. That got it working, and it took me to a splash page that said “All-in-One Event Calendar Notice: You are using the Lite Calendar. This edition of the plugin is no longer supported” And then a button to “Upgrade to the Standard Calendar for free”
    I pressed that which installed an update, then automatically removed the old plugin. Now it works fine 🙂

    Have tried all of the above solutions and I still get errors. I am very frustrated with my choice of calendars for WordPress. Anybody know what to do with this message?

    Fatal error: Cannot redeclare class vevent in /home5/tamarac9/public_html/wp-content/plugins/all-in-one-event-calendar/lib/iCalcreator-2.10/iCalcreator.class.php on line 6364

    Ok. Nevermind. Found other troubleshooting here:
    http://community.time.ly/forum/troubleshooting/theme-and-plugin-conflicts_aa/46-not-sure-if-you-have-a-theme-or-plugin-conflict-test-here

    And tested for conflicts with my other plugins. Apparently it is conflicting and I can now get it to work.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘The plugin does not have a valid header.’ is closed to new replies.
Skip to toolbar