Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security » The plugin does not have a valid header.

  • Resolved losdos

    (@losdos)


    When installing the plugin, then pressing “Activate” I received the following error message page:

    “The plugin does not have a valid header.”

Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Did you try to deactivate it and reactivate it to make sure you don’t get the header error again?

    Regarding the Full WAF mode, upload this script in the site folder and run it, that will tell you which firewall is loaded (this site or the one in the parent folder):

    <?php
    header('Content-type: text/plain');
    echo "auto_prepend_file: ". @ini_get('auto_prepend_file');
    

    It’s definitively using the parent:
    auto_prepend_file: /home/****/public_html/wp-content/nfwlog/ninjafirewall.php

    I’ll disable, rename php.ini and comment out .hta once more….

    Plugin Author nintechnet

    (@nintechnet)

    Maybe try to rename your php.ini files to .user.ini instead (you may have to wait 5mn afterwards, the time PHP reloads them).

    disabling NF, renaming parent php.ini and commenting out .htaccess allowed activation and place me where it should, in WordPress WPF mode. Then allowing NF to make the changes to Full WAF mode was successful.

    Would you like me to do any more testing?

    Plugin Author nintechnet

    (@nintechnet)

    Perfect.
    Thanks for your help, that solved that invalid header issue which is rather odd btw!
    I have to release v4.0.1 tomorrow or monday and I could add this fix to it too.

    Sweet, thank YOU for the awesome firewall!

    BTW, my hosting plan is with InMotion Hosting.

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.